Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 7 voices.

Last updated by alexG-29 8 months ago.

Assigned support staff: Diego Pereira.

Author Posts
March 24, 2019 at 6:03 pm #3448909

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Updating ticket status

August 1, 2019 at 9:14 am #4320085

jernejO

Hello. for me WPML still doesn't work with WP CLI very nicely. For one thing, if you use "wp media regenerate" only main language images are actually properly regenerated (the file on disk is the same anyway, but it seems there need to be some DB changes handled by WPML).

Any thoughts on that?

Found a similar post here with no answer: https://wpml.org/forums/topic/_wp_attachment_metadata-not-updated-after-media-regeneration/

October 30, 2019 at 1:12 pm #4855869

alexG-29

Hi Diego,

I experience issues updating WPML from 4.2.1 (reported in this post to be working) and plugins with wp-cli :

command :

 wp plugin update --all 

summary :

+-----------------------------+-------------+-------------+--------+
| name                        | old_version | new_version | status |
+-----------------------------+-------------+-------------+--------+
| acfml                       | 1.0.4       | 1.5.0       | Error  |
| advanced-custom-fields-pro  | 5.7.9       | 5.8.6       | Error  |
| wpml-multilingual-cms       | 4.2.1       | 4.3.1       | Error  |
| wpml-string-translation     | 2.10.1      | 3.0.1       | Error  |
| wpml-translation-management | 2.8.1       | 2.9.0       | Error  |
+-----------------------------+-------------+-------------+--------+

More details (an example of the same error for all) :

Downloading update from https://wpml.org/?download=1097589&version=1.5.0&site_key=aaaKEYaaaa&site_url=https%3A%2F%2Fdomain.com%2Fwp&wpml_version=4.2.1...
Using cached file '/home/.wp-cli/cache/plugin/acfml-1.5.0.'...
Unpacking the update...
Warning: The package could not be installed. "PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature"

ie : the url https://wpml.org/?download=1097589&version=1.5.0&site_key=aaaKEYaaaa leads to the changelog "WPML String Translation 1.5.0", dated August 27, 2012

Adding new plugins by dashboard is disabled on my config and I am not planning to remove it.

Do you have any insight about it ?

Best regards,
Alex