This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by maryC-2 3 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
July 3, 2019 at 6:01 pm #4138483

maryC-2

I have WPML running on hidden link with "Language URL format" set to "Different languages in directories".

WPML shows a message saying "It looks like languages per directories will not function" (see attached screenshot).

When I ran the WPML validation, it works for the following URL:
hidden link

I was able to see the EXPECTED RESULTS in "View Source":
<!--hidden link;

However, the WPML validation FAILS for the following URL:
hidden link

It only returned BLANK instead of the expected result.

Why does the second URL fail? How to resolve this issue?

July 4, 2019 at 12:16 am #4139365

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. In some cases the validation error message can be a false positive, in order to determine it, please, confirm if the translations for the url structure with the 'zh-hant' code is working properly, if so, then you can safely ignore this error message. Additionally you can try this workflow to get rid of this message:

1- Make sure that you have translations for your pages so that they can be properly tested.

2 - In your WordPress Dashboard > WPML > Languages > URL Format, change to the Language as Parameter option and resave your permalinks structure.

3 - Change back to the 'languages in directories' option and make sure you don't have actual directories for the language you are having issues.

4 - Make sure there are no redirects in your .htaccess file

5 - Please read: https://wpml.org/faq/server-setting-for-languages-in-directories/ and
https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/

Please, let me know if the above helps to fix your issue. Have a nice day.

July 4, 2019 at 7:43 pm #4146279

maryC-2

Hi Marcos,

I agree with you that the error message might be a "false positive" and that it is a known WPML issue. I've also tried your Steps 1-3 but the "false positive" error message still persists.

As far as I know, we have not modified the .htaccess file. If you'd like to attain a copy of my .htaccess file to double-check, just let me know.

There is a new problem with WPML which I need a resolution URGENTLY.

- I started adding Chinese text for a post and this error related to the WPML plugin appeared (see Forwarded Message below)
- the new Chinese content that I just inserted is saved but will not display: hidden link
- it also is not included in the list of posts as being a Chinese post

Please advise ASAP what the cause of this problem is.

-------- Forwarded Message --------
Subject: [Calculated Traveller Magazine] Your Site is Experiencing a Technical Issue
Date: Thu, 4 Jul 2019 17:22:04 +0000
From: WordPress
To: mary

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugins, WPML Translation Management.

First, visit your website (hidden link) and check for any visible issues. Next, visit the page where the error was caught (hidden link) and check for any visible issues.

[..]

Error Details
=============
An error of type E_ERROR was caused in line 41 of the file /home/graphij5/public_html/wp-content/plugins/wpml-translation-management/classes/translation-jobs/class-wpml-tm-unsent-jobs.php. Error message: Uncaught TypeError: Argument 1 passed to WPML_TM_Unsent_Jobs::prepare_unsent_job_for_notice() must be an instance of WPML_Translation_Job, bool given, called in /home/graphij5/public_html/wp-includes/class-wp-hook.php on line 286 and defined in /home/graphij5/public_html/wp-content/plugins/wpml-translation-management/classes/translation-jobs/class-wpml-tm-unsent-jobs.php:41
Stack trace:
#0 /home/graphij5/public_html/wp-includes/class-wp-hook.php(286): WPML_TM_Unsent_Jobs->prepare_unsent_job_for_notice(false)
#1 /home/graphij5/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array)
#2 /home/graphij5/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array)
#3 /home/graphij5/public_html/wp-content/plugins/wpml-translation-management/inc/translation-jobs/helpers/wpml-update-translation-data-action.class.php(114): do_action('wpml_tm_new_job...', false)
#4 /home/graphij5/public_html/wp-content/plugins/wpml-translation-management/inc/translation-jobs/helpers/wpml-update-translat

July 5, 2019 at 6:29 pm #4153399

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 8, 2019 at 7:14 pm #4165309

maryC-2

Can I check the status of this please. Thanks so much!

July 9, 2019 at 12:56 am #4166341

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details and sorry for the bit of waiting here due the weekend. I tried to connect to your website using the provided FTP access details but unfortunately they don't seem to be correct. Can you please review it? Please, test the access details before submiting them, it will assure we don't have any extra waiting in the resolution of your issue.

A private reply is enabled for you again, so you can safely resend any access details. Thank you for your collaboration and continued patience, have a nice day.

July 9, 2019 at 4:37 pm #4173157

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Unfortunately it still doesn't work, the provided details in your most recent replies doesn't seem the FTP details we need, instead it is the access details to your database management tool (phpMyAdmin). We need to FTP details in this format:

FTP host address
FTP user
FTP password

The FTP details allow us to turn on your WP_DEBUG mode, list files, edit files, see error logs, htaccess content and so on, this is why it is so important for our support efforts (see https://wordpress.org/support/article/ftp-clients/). Please, ask you host to provide us with the valid FTP access, if it is possible, test it before submiting your reply. A private reply is ebabled for you again, thank you for your continued patience and understanding, have a nice day.

July 11, 2019 at 2:07 am #4185073

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. I took another detailed look in your website and indeed the message is a false positive as your website secondary language is working properly. For example:

1 - It is possible to access the chinese version of the 'Alight in luxury at Riad Dar Les Cigognes Marrakesh Morocco' post at: hidden link

2 - The post 'Alight in luxury at Riad Dar Les Cigognes Marrakesh Morocco' is being listed as a chinese 'translation in progress' in your WordPress Dashboard > Posts

3 - Your website is switching language properly according my tests in your homepage.

A possible reason for the warning message in your language url setup is a block of your server for 'fopen' calls. Please, contact your host server support in order to make sure that fopen is enabled on your server

Please, let me know if it helps and if you need any additional assistance and clarifications. Have a nice day.

July 14, 2019 at 12:50 pm #4205575

maryC-2

My issue is resolved now. Thank you!