This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I use WPML together with Yoast. When sharing a post on Facebook using Facebook Debugger it makes it appear in the set language, not in the default language.

Solution: WP Engine cache setting caused the problem and had to be disabled by their support.

This topic contains 3 replies, has 2 voices.

Last updated by christianR-3 5 months ago.

Assigned support staff: Marcel.

Author Posts
May 15, 2019 at 1:45 pm #3817183

christianR-3

I am trying to: Share a post on Facebook and make it appear in its set language, not in the default language (using Facebook Debugger).

Link to a page where the issue can be seen:
hidden link

I expected to see: The page showing spanish title and description

Instead, I got: Sharer redirects to default language post and and ignores canonical url and other og:tags that seem to be set properly.

May 15, 2019 at 5:04 pm #3818989

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Christian,

Thank you for contacting WPML Support.

Could you please try this with our new YOAST SEO "glue" plugin? You can download it here: https://wpml.org/account/downloads/

Once you installed it, please configure it like described here:
https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

The glue plugin is just a few weeks old. The functionality was handled before in WPML Core.

Please let me know. Please also add following code to your functions.php to increase WP Memory Limit:

define ('WP_MEMORY_LIMIT', '256M'); 

add it before

 /* That's all, stop editing! Happy blogging. */ 

Best Marcel

May 16, 2019 at 6:00 am #3822121

christianR-3

Thanks for the info! I did not work. In the end we found out it was a WP Engine cache setting causing the problem and that had to be disabled by their support.

Kind Regards,
Christian

May 16, 2019 at 6:00 am #3822123

christianR-3

My issue is resolved now. Thank you!