This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

WPML Woocommerce attributes not showing for translation.

Solution:

In this case, WPMl and its add-ons including WooCommerce Multilingual were not updated. After updating everything, re-save the translations of attributes. Also please clear any cache from your site and see if it helps to solve the problem.

Relevant Documentation:

https://wpml.org/documentation/related-projects/woocommerce-multilingual/

This topic contains 6 replies, has 2 voices.

Last updated by joaoM-18 5 months, 1 week ago.

Assigned support staff: Itamar.

Author Posts
May 6, 2019 at 3:45 pm #3750595

joaoM-18

I am trying to: translate product attributes

The attributes appear on the main language but on the other languages even though they are translated the show up in the primary language.

Check here the english version [ additional information tab ] - hidden link

And the spanish version [ additional information tab with english content ] - hidden link

The field ( in wordpress bakcoffice) show as not attributes available to translate.

thanks in advance

May 6, 2019 at 4:04 pm #3750911

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please confirm that the issue is what I show on the attached screenshot.

Please correct the following and see if it helps to solve the problem.

1. Update WPML, WooCommerce Multilingual, and all of the other WPML add-ons. I can see that they are not updated on your site. So please update everything. In addition, please also update WooCommerce itself.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

2. By looking at the debug info that you have attached I can see that your server is running an older version of MySQL and also your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.6 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if they help?

Thanks,
Itamar.

May 6, 2019 at 4:44 pm #3751243

joaoM-18

Hi Itamar,

> Updated WPML, WooCommerce Multilingual and all the other WPML add-ons.
> Raised WP Memory Limit to 256M.

It didn't work.
Do you have more suggestions?

Thank you for your help.

May 6, 2019 at 8:18 pm #3752539

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

After updating everything, please re-save the translations of attributes.
Also please clear any cache from your site and see if it helps to solve the problem.

If it does not help please let me have access to your site so I can continue to check things.
If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

May 7, 2019 at 9:13 am #3755761

joaoM-18

Hi Itamar,

Followed your instructions and apparently it is solved.
If anything changes we'll talk to you again.

Thank you for you help.

May 8, 2019 at 11:43 am #3766163

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Great! I'm glad that it is solved now.

Could you please mark this ticket as resolved?

Thanks,
Itamar.

May 8, 2019 at 1:11 pm #3767021

joaoM-18

My issue is resolved now. Thank you!