Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Beda 4 years, 11 months ago.

Assigned support staff: Beda.

Author Posts
March 27, 2015 at 5:26 pm #589578

carlosV-5

I am trying to: Browse the products on my website in my primary language.

I visited this URL: hidden link

I expected to see: My Residential Products

Instead, I got: and Error 404 page (All 404's redirect to home page)

March 27, 2015 at 5:29 pm #589582

carlosV-5

The product/category taxonomy has been messed up and I don't know why.

This is what it was:
hidden link

This is what it is:
hidden link

It's in Spanish but pointing to english content but none of the products on the left widgets are working either.

March 27, 2015 at 9:07 pm #589696

carlosV-5

I temporarily had to create 3 menu's for the product categories on the english Shop side bar. When a user still goes to the working product category link, the items on the body of the page link are still broken because of the taxonomy.

March 29, 2015 at 6:03 pm #590091

Beda
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch ) Italian (Italiano )

Hello Carlos

I will take care of your ticket.
Could you please share your Debug Informations with me?
http://wpml.org/faq/provide-debug-information-faster-support/

In order to solve this issue, please could you double-check a few configurations?

1. Make sure in Dashboard > Settings > Permalinks the Product Category base is saved in English
(product-category)
2. Double check in WPML > Translation Management > Multilingual Content Setup > Custom Posts if the regarding Slug is correctly translated to spanish
3. Check the if the String (permalink) is also translated in WPML > String Translations

In case you see Spanish Slugs in
WPML > Translation Management > Multilingual Content Setup > Custom Posts
as original slugs, instead of the english slug, please follow as mentioned below:

1. First disable the "Translate custom posts slugs" option:
WPML > Translation Management > Multilingual Content Setup

2. From the String Translation admin screen search specifically for the English slug "product-category".
Delete it.

2. Next search specifically for the Spanish slug: "categoria-producto"
Delete this also.

3. Go back to:
WPML > Translation Management > Multilingual Content Setup
and re-enable the "Translate custom posts slugs" option.

4. Scroll down to the Custom Posts in the same Configuration Page,
and enable "Use different slugs in different languages".
This time the original English slug will be shown correctly in English.

5. Proceed to translate the slug to Spanish right there on that screen.

This should solve the issue.

Please let me know if it persist.

Thank you

The topic ‘[Closed] WPML + WooCommerce Category/Product Taxonomy has been broken for primary lang’ is closed to new replies.