Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 5 voices.

Last updated by Wolfgang 6 years, 11 months ago.

Assigned support staff: Dominykas.

Author Posts
January 2, 2013 at 9:29 am #93838

Esa

Hello folks of WPML,

I'm building a Woocommerce webshop in three languages; Finnish, Swedish and English.
Using uptodate WP, WooCommerce and WPML.

I'm having the same problem as described by many users, only the main language permalinks works, others give a 404. I've read other threads and tried everything, but can't find answers, how to configure?

Could you please advise me?
Address of the shop is hidden link
I can provide you with the access to the backend.

Thank you!

January 2, 2013 at 10:40 am #93851

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Esa,

Lets see what can be done.

# Have you also installed the "Woocommerce Multilingual plugin" ?
http://wordpress.org/extend/plugins/woocommerce-multilingual/

# Under "WooCommerce > General Options" the "Region" is Finland I assume?

January 2, 2013 at 11:26 am #93858

Esa

Hello andreas.n,

WooCommerce Multilingual is installed
the region is Finland

January 2, 2013 at 12:17 pm #93873

Andreas Neuber
Supporter

Languages: English (English ) German (Deutsch )

Hello Esa,

Thanks!
I will involve another developer from our team with more WooCommerce experience (esp. since you are not the only user with this porblem) and come back as soon as possible.

January 4, 2013 at 7:58 am #94141

Esa

Hello,

do you have any updates about the permalink problem?

The translated product category and single product permalinks still return 404.
I'm just wondering, are those permalinks translated by WPML or WooCommerce?
Translating products and attributes and stuff at the backend goes without problems.

I enabled WP_DEBUG and PHP error logging.
The content of error_log is:

[04-Jan-2013 07:16:48] PHP Notice: session_start() [<a href='function.session-start'>function.session-start</a>]: ps_files_cleanup_dir: opendir(/var/lib/php5) failed: Permission denied (13) in /var/www/vhosts/peruswordpress.fi/porvoonkukkatalo/wp-content/plugins/woocommerce/woocommerce.php on line 138

Nothing very helpful here.

The more links I click, the more weird things appear:
There's a 'Products' widget on a sidebar hidden link

Clicking the 'Roses' category, assumed URL is:
hidden link
but it actually redirects to:
hidden link

Any suggestions?

Thank you for every piece of help.

January 4, 2013 at 3:16 pm #94308

Dominykas

Hi Esa,

This is a strange issue, could you send me an e-mail with your site administrator credentials to take a look from back-end? or setup a test site?

January 4, 2013 at 4:02 pm #94314

Esa

Hello Dominykas,

I'll setup an admin user for you.
Please, provide me with your email address, couldn't find it on your profile page.

January 7, 2013 at 8:13 am #94519

Esa

Hello Dominykas,

could you please tell me where to send the user credentials?

January 8, 2013 at 7:51 am #94787

Esa

I still need assistance.
Any help would be highly appreciated.

January 10, 2013 at 8:20 am #95407

Esa

User credentials mailed to Dominykas 8.1.2013.

WP is installed in the root directory.
htaccess is writable.
mod_rewrite is enabled.
fopen is allowed.
safe_mode is On

Duplicated the site onto another server:
testshop.eccola.fi

Same issue here, using /%postname%/ and Different languages in directories,
product categories and single products permalinks return 404.

Using default permalinks and Language name added as a parameter works, but is absolutely not an option.

Could someone please respond to this message?

January 10, 2013 at 10:54 am #95440

Dominykas

Hi Esa,

My apologies for the delay. I got your site credentials and will take a look right now.

January 10, 2013 at 11:05 am #95443

Esa

Hello,

I somehow managed to fix some things using development version of woocommerce-multilingual and made some settings, blindfolded.
It worked so-so, only now all /product-category/ etc. slugs are in English. So, not resolved, yet.

January 10, 2013 at 8:17 pm #95680

Sarah

We are having this same problem too.

http://wpml.org/forums/topic/multilingual-product-slugs-404-after-saving-woocommerce-pages-settings/

Have you had any luck figuring this problem out?

January 11, 2013 at 8:02 am #95729

Esa

Hello Sarah,

this is very complex combination of software were using here. I'm sure the developers of WPML are working hard to fix those bugs and make our lives easier.

I've had no "luck" (that's "assistance") with these problems, yet. Maybe we just have to wait.

The worst thing is that our projects usually have deadlines, and in some cases, we pay penalty for delays.

January 11, 2013 at 9:05 am #95739

Esa

Sarah,

development version of woocommerce-multilingual adds context "URL slugs - woocommerce" to String Translation module. At the moment, you can only translate the slug "product", which in my case has wrong default string, it should be in Finnish.

From woocommerce_wpml.class.php:
//taxonomy slug translation is not ready yet, return no translation

This looks promising.

The topic ‘[Closed] WPML/ Woocommerce – Product permalinks issues’ is closed to new replies.