This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 4 weeks, 1 day ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
September 9, 2019 at 2:05 pm #4537851

selimU-2

Im trying to upload products in the 1st language english, i keep getting the error "your service has terminated the import process". I contacted my server, they increased max_execution_time, but it seems like its terminating the import process even earlier now, so it didnt solve the issue. I use the newest version of WP All Import and WPML. Debug info has been given.

September 10, 2019 at 1:52 am #4540765

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. Please, try the following:

1 - Make sure your wp memory limit is set to our minimum requirements as described at: https://wpml.org/home/minimum-requirements/. I see it is set as 40MB from your debug info, it is not enough to run WPML.

2 - Disable all the plugins except those needed for the import process, such as WPML, the All Import, WooCommerce, etc and try the import process again.

Please, let me know if works for you, have a nice day.

September 12, 2019 at 9:30 am #4559793

selimU-2

When checking our WordPress status, it shows 2GB memory limit, are you sure its 40 MB? i have now also added it via wp-config, to be sure its indeed 2GB.
is it really necessary to disable plugins and test it that way? because we only have necessary plugins active, like Google Analytics or WP Rocket and so on. SInce we want to have daily imports by cron job, its not a solution for us to de-active specific plugins when importing 🙁

September 13, 2019 at 12:19 am #4564489

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 16, 2019 at 4:26 pm #4582641

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I tried to access your WordPress Dashboard with the provided details but it doesn't seem to be correct, can you review it please? From your provided screenshots your server reports a capacity issue, which means when trying the import process it is exceed your current server resources and then it terminates without completation, in this case you can confirm it is not a WPML usage issue testing the same process in this test sandbox environment: hidden link following these instructions:

1 - Click the one click login provided above to the sandbox test environment.

2 - Setup the WPML plugin to match the setup you have in your website.

3 - Install the relevant plugins (WP All Import, WooCommerce, etc).

4 - Try the import process.

Please, let me know if you see the same issue, have a nice day.