This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: WPMUDEV Domain Mapping not working with WPML.

Solution: The DOMAIN MAPPING plugin by 'wpmudev' is not in our compatibility list here https://wpml.org/documentation/plugins-compatibility/.

That said, it may not work as expected. If you set WPML Language settings to "Different languages in directories" then having the second languages load in subfolder such as rootdomain.com/site1 is expected.

If you want to use different languages per domain we recommend not using domain mapping and use the method outlined on this tutorial: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Relevant Documentation: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Author Posts
October 20, 2018 at 5:06 pm #2834405

Finca Development Team

Hello
I am using WPMUDEV Domain Mapping
After domain mapping i check WPML setting and it do not change Language URL format

Different languages in directories It not showing Mapped domain, it shows site sub folder
(rootdomain.com/site1 it must be mydomain.com)

October 22, 2018 at 6:19 pm #2839415

Ricardo Alday

Hi,

Thank you for contacting WPML support.
The DOMAIN MAPPING plugin by 'wpmudev' is not in our compatibility list here https://wpml.org/documentation/plugins-compatibility/.

That said, it may not work as expected. If you set WPML Language settings to "Different languages in directories" then having the second languages load in subfolder such as rootdomain.com/site1 is expected.

If you want to use different languages per domain we recommend not using domain mapping and use the method outlined on this tutorial: https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Hope that helps,
Ricardo

October 22, 2018 at 6:54 pm #2839544

Finca Development Team

My issue is resolved now. Thank you!