This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
How to translate Yoast breadcrumb - Yoast page for Content Type for "Projects"
Solution:
Since this is in fact admin string (the one you set in Yoast administration panel), I registered this string to be translatable through XML, and is now available within string translation:

<wpml-config>
    <admin-texts>
        <key name="wpseo_titles">
            <key name="bctitle-ptarchive-project"/></key>
    </admin-texts>
</wpml-config>

I have put this into WPML -> settings -> custom XML configuration

I think that this will clear up on what was behind this:
Relevant Documentation:
https://wpml.org/forums/topic/yoast-breadcrumb-translations-not-working/#post-2575257

This topic contains 3 replies, has 2 voices.

Last updated by Michael Krone 2 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
July 30, 2019 at 8:17 pm #4310429

Michael Krone

Tell us what you are trying to do?
We changed the breadcrumb in Yoast from "Project" to "Healthy Activity Ideas" [picture Yoast settings.png]
Now we are using WPML to translate the site, but can't find where to change the breadcrumb to French. [Example in picture CHWM1.png]
Please let us know where to change this?
Thank you.
Michael
michael@excellence.ca

Is there any documentation that you are following?
Just material from your support blogs.

Is there a similar example that we can see?
hidden link

What is the link to your site?
hidden link

July 31, 2019 at 6:40 am #4311887

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me if the issue is that the "Healthy Activity Ideas" isn't translating when on page such as hidden link, even though it translates properly when you are on hidden link.

Can you tell me if you tried the following:
- disabling any caching plugins you might have
- checking if this string is available within string translation and translating it there

If none of this works, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

August 1, 2019 at 6:13 am #4318973

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

We have changed the Yoast page for Content Type for "Projects" in English.

This was an information which made a difference :).

So something like this?
hidden link

Since this is in fact admin string (the one you set in Yoast administration panel), I registered this string to be translatable through XML, and is now available within string translation:

<wpml-config>
    <admin-texts>
        <key name="wpseo_titles">
            <key name="bctitle-ptarchive-project"/></key>
    </admin-texts>
</wpml-config>

I have put this into WPML -> settings -> custom XML configuration

I think that this will clear up on what was behind this:
https://wpml.org/forums/topic/yoast-breadcrumb-translations-not-working/#post-2575257

Let me know if that's working for you!

Regards,
Bruno Kos

August 2, 2019 at 3:17 pm #4331075

Michael Krone

My issue is resolved now. Thank you!