Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
December 7, 2016 at 4:32 pm #1154114

Patrick

I am trying to:
Active Visual Composer translation (l'éditeur de traduction WPML)

URL of (my) website where problem appears:
Available privately upon request.

I expected to see:
"l'éditeur de traduction WPML" getting activated

Instead, I got:
This action is not allowed

Steps to duplicate the issue:

In the admin, when I go to plugins, I get the following message above my plugins:


Encore une étape avant de pouvoir traduire Visual Composer

Vous devez activer l'éditeur de traduction WPML afin de traduire plus aisément.
L'activer maintenant

When I click "L'activer maintenant", I get the error "This action is not allowed."

I can provide a link to the dev privately if you need.

- The button calls the action "wpml_set_translation_editor"
- The Response is {"success":false,"data":"This action is not allowed"}

December 8, 2016 at 12:40 pm #1154946

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

Thank you for contacting the WPML support. We are happy to help you.

Please try the following steps after a backup and let me know your feedback.

1) Visit WPML>>Translation Management page
2) Click on *Multilingual Content Setup* tab
3) Choose *Use the translation editor* option for *How to translate posts and pages*
4) Save the settings and confirm you are still getting the alert or not

Please check attached image for more details.

--
With Regards

Bigul

December 8, 2016 at 12:51 pm #1154962

Patrick

OK, that seems to be working (at least, I am no longer getting the alert). However, my pages are still not translated side-by-side as seen in your video hidden link

In fact, activating it seems to have made no change at all. Is that normal ?

December 8, 2016 at 2:47 pm #1155108

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Please share few screenshots and steps to replicate for a clear picture.

--
With Regards

Bigul

The topic ‘[Closed] wpml_set_translation_editor returns "This action is not allowed"’ is closed to new replies.