This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 40 replies, has 2 voices.

Last updated by Carlos Rojas 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 17, 2018 at 3:24 pm #2653625

Vasileios Chouliaras

Hi i have a problem with wpml and wprocket.
All works ok. The only thing is that when i change language the message "Your cart is empty" from cart doesn't change to the new language as should be.I have English and Greek.

When I join for the first time with eng language the message remains at English when changes to Greek

When I join for the first time with gr language the message remains at Greek when changes to English.

When wprocket is disabled this is not happening.

I talked with them and they told me that this is an issue with wpml.

At string translation is already translated.

Thanks

We solved this at here
https://wpml.org/forums/topic/wpml-and-wprocket/

But wprocket relaesed an update

updated to version 3.1.1.1 August 10, 2018. As i see the changelog

1
Regression fix: Prevent a PHP fatal error "undefined function" on activation on Apache, because the fuctions were in a file not loaded in the activation hook

and since 3.1 version
Bugfix: Prevent the plugin from removing custom cron schedules if the Google Tracking Add-on is not active
Bugfix: Prevent a PHP Fatal Error is a call to a deprecated WP Rocket function is made by another plugin
Bugfix: Improve URL to path conversion function to prevent errors with some relative CSS/JS URLs during minification/combine/remove query strings
Bugfix: Add more default exclusions to combine Javascripts files to prevent errors
Bugfix: WP Rocket can now be correctly disabled if activated on the network level on multisite
Bugfix: Correctly exclude the REST API on multisite sub-sites
Bugfix: Correctly recreate the wp-rocket-config folder if it doesn't exist
Bugfix: Correctly position the show sidebar slider for RTL languages
Bugfix: Don't display the show sidebar slider on the license screen

The problem appeared again

August 17, 2018 at 5:16 pm #2654356

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

Please follow this steps:
- Go to WPML -> Languages -> Language filtering for AJAX operations -> Select this option -> Save the changes.
- Flush the cache memory in WP Rocket.

Does the issue persists?

Kind regards,
Carlos

August 27, 2018 at 10:02 am #2677585

Vasileios Chouliaras

Thanks for the reply and sorry i was away.
This option was already activated.

I deactivated and activate it again.
Clear cache from wpml then in incognito mode.

Still the same.

August 27, 2018 at 7:50 pm #2679854

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

This seems to be an interaction issue. Could you test if the issue persists with another of the cache memory plugins that appear in our compatiblity list: https://wpml.org/documentation/plugins-compatibility

Best regards,
Carlos

August 29, 2018 at 10:12 am #2685879

Vasileios Chouliaras

Hi Carlos and thanks for your reply.
Wprocket is "one way" for us.

Is the best "for our purpose" cache plugin.

And i think is the n1 paid plugin cache.

August 29, 2018 at 4:06 pm #2687200

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Best regards,
Carlos

August 30, 2018 at 8:13 pm #2691828

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

My first step was to update all outdated plugins, however, after this I got an error in the backed related to the 'NETSTAR-GR Ltd - WooCommerce Eurobank Payment Gateway' plugin, which I disabled and the error disappeared.

However I got a 500 error when I tried to reproduce the original issue (the untranslated string).

I activated WP Rocket in the backend and flushed the cache memory, but the 500 error still persists in the front end. Could you take a look at this issue and if necessary re-install the dev site?

Best regards,
Carlos

August 31, 2018 at 8:41 am #2693034

Vasileios Chouliaras

Thanks for the reply. I think the 500 error is from plugin mailchimp forms by optin cat {if you update this plugin}. I am out of offlice to deactivate it. Pls deactivate it and Check again. Thanks

August 31, 2018 at 6:10 pm #2694927

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thanks for your message.

I have disabled all plugins except WPML plugins and Woocommerce and activated a default WordPress theme, however I still get an error message in the Javascript console of the browser while trying to scan the theme in WPML -> Theme and plugins localization.

I suspect this is the cause of the issue. Could you fix this issue and let me know when this is done?

Alternatively I could make a copy of the site and run further tests in a local environment and check if the issue persists there.

Looking forward to your answer.
Best regards,
Carlos

September 3, 2018 at 2:05 pm #2699845

Vasileios Chouliaras

Carlos thanks for your reply.
If is possible make a local copy and work on it because i didn't understand about the error in console.
Thanks for all

September 3, 2018 at 6:13 pm #2700723

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I'm more than happy to create a copy of the site and test it locally, however the Wordfence plugin doesn't allow me to create the copy with Duplicator plugin. I kindly ask you to configure Wordfence to let Duplicator make the copy or delete it from the site temporarily.

Looking forward to your answer.
Best regards,
Carlos

September 4, 2018 at 1:22 pm #2703524

Vasileios Chouliaras

Yes, do everything you want. There is no problem. Thanks for all

September 5, 2018 at 1:34 am #2705045

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

If would like to ask you to follow this steps:
- Go to Plugins -> Deactivate 'SUMO Reward Points' plugin.
- Flush the cache memory from WP Rocket.

Does the issue persists?

Note: In local 'SUMO Reward Points' plugin throws an error.

Best regards,
Carlos

September 5, 2018 at 3:37 pm #2708007

Vasileios Chouliaras

No still the same. The problem is from wpml. Whe have faced this again if you check it here
https://wpml.org/forums/topic/wpml-and-wprocket/

September 5, 2018 at 6:56 pm #2708568

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I tried to access the site but it seems that the credentials aren't working. Could you double check the credentials provided in your private message and let me know when they are working again?

This way I can compare the site in local with the site in your environment.

Looking forward to your answer.
Best regards,
Carlos