This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 13 replies, has 2 voices.

Last updated by Laura 4 months, 3 weeks ago.

Assigned support staff: Laura.

Author Posts
May 29, 2019 at 8:22 am #3913009

naorN

I am trying to:
https://wpml.org/forums/topic/keep-displaying-translations-marked-as-translation-needs-update/
not working
Link to a page where the issue can be seen:
https://wpml.org/forums/topic/keep-displaying-translations-marked-as-translation-needs-update/
I expected to see:

Instead, I got:

May 29, 2019 at 8:35 am #3913195

naorN

how much time to solve the problem more then 12 hours?

May 29, 2019 at 3:37 pm #3917003

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

I'm not sure I understand your issue. You linked a topic from 7 years ago where multiple issues were touched. Could you please better explain, and if possible add your WPML debug information?

You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

May 29, 2019 at 3:41 pm #3917045

naorN

The text was translated two days ago and after ,I changed the main page ,He said that I have to update everyone why?

May 29, 2019 at 3:51 pm #3917087

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

did you check the box "Minor edit - don't update translation"? If you didn't, it's expected that WPML asks you to update translations.

If you checked it and it still asks you to update translations, please add your WPML debug information.
You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

May 29, 2019 at 4:06 pm #3917215

naorN

I extend the memory to 256 it is not the problem.
"Minor edit - don't update translation"? If you didn't, it's expected that WPML asks you to update translations.?
how to do that what the steps?

May 30, 2019 at 6:25 am #3920681

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if you don't want to update translations when you change things in the original pages, you need to check the box "Minor edit - don't update translation". Please check the attached image.

Let me know if this helps you or if you need further assistance.

May 30, 2019 at 6:29 am #3920711

naorN

The checkbox is not available in all the pages why ?
Thier is faster options not to check every page ?

May 30, 2019 at 6:31 am #3920737

naorN

Except that ,thier are option to copy the menus to the other languages and then to edit ?

May 30, 2019 at 6:39 am #3920757

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I can't know why the checkbox is not available on all pages. Can you provide me some screenshot?
At the moment there isn't another option for not getting the update request. But you can ignore it.

About the menu question, please open a new ticket. We try to have only one issue per ticket, so it's easier for others to search the forum. This also allows supporters to be faster and more efficient. Also please notice we have supporters for several languages if you are more at ease writing in a different language than English.

May 30, 2019 at 7:24 am #3920937

naorN

So to do that before I am editing or I can do latter and It will come back to the original text, it sounds wierd that I have to do this to all the pages

May 30, 2019 at 7:35 am #3920985

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the idea is that first you create your site, and then you translate it, not that you do the 2 things at the same time.

You need to check the box BEFORE saving the original page, once you've done you'll get the icon for "translations need updates" and the only way to remove it is to save the translations again.

May 30, 2019 at 7:44 am #3921011

naorN

I just need to this in the main page of my language?

May 30, 2019 at 8:08 am #3921137

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

no, you need to do this on every page in your original language, if you edit them and you don't want to update the translations.