Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Alfredo 6 years, 3 months ago.

Assigned support staff: Tia.

Author Posts
August 25, 2015 at 10:10 am #686690

Alfredo

I am trying to: To set correct browse redirection for main language

URL of (my) website where problem appears:

I expected to see:

Instead, I got:

August 25, 2015 at 10:10 am #686691

Alfredo

Hello.
I have updated all plugins with new release, but i have some iusses yet.
Expecially when I click on "Visit site" ont top right admin menu, and when I click on frontend on flags I have a bad redirect on default language,
I try to explain better. For my default language the url should be hidden link and for second language
hidden link. Ok, as said when I click on visit site by admin on italian flag (default) on forontend, it redirect me on hidden link giving me a "page not found"
Thanks and regards.

August 25, 2015 at 3:18 pm #689289

Tia

Hi, Alfredo and thank you for contacting support. I am looking into your issue and will update you shortly.

August 25, 2015 at 5:19 pm #689408

Tia

Hi, Alfredo.

I see your debug information and was able to repeat your issue.

Please ensure the settings for using languages as directories reflect the directions on the following pages:
https://wpml.org/faq/server-setting-for-languages-in-directories/
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

If you feel the settings reflect those pages properly then our next step is for me to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

August 26, 2015 at 4:29 pm #690454

Tia

Thank you for that information. I am looking at your site and will reply as soon as possible.

August 26, 2015 at 5:02 pm #690483

Tia

Alfredo, can you try again with minimal set up?

** IMPORTANT ** Please back up site files and database before performing the next steps.

* 1st Scenario *
- Deactivate all non-WPML plugins
- Keep Enfold Child theme enabled
- Check to see if wp-admin works

* 2nd Scenario *
- Switch the theme to a WordPress default (such as Twenty Fifteen)
- Keep all plugins enabled
- Check to see if wp-admin works

* 3rd Scenario *
- Deactivate all non-WPML plugins
- Switch the theme to a WordPress default (such as Twenty Fifteen)
- Check to see if wp-admin works

Please let me know your outcome.

August 27, 2015 at 8:10 am #690880

Alfredo

Hello Tia.
Before to open the ticket I have tried these scenarios, because it isn't the first ticket I open after WPML and WP last updates.
This iusse is not for wp-admin iusse, but as said, but for a badurl language format. I attach a screenshot of my settings. For Italian shound be hidden link (while for english is hidden link).
Well if i try to see my front end site clicking on "Visit site" on left top of admin panel i'm redirect by default to hidden link and I have a page not found.
Please, because it's not the first iusses I have to resolve, and It take more than two weeks to solve other, help me to solve this iusse, or if you think it's better reassign it to another that match with my local time (previous iusse was solved by Sumit and Andrè).
You have temporary access to all.
Thanks and regards.

Schermata 2015-08-27 alle 10.06.15.png
August 27, 2015 at 3:02 pm #691427

Tia

Thank you for the information. I just needed to rule out those possibilities before going further.

I appreciate your patience. I know this must be frustrating for you and I apologize.

I am in the process of further debugging and will update you as soon as possible.

August 27, 2015 at 5:06 pm #691564

Tia

Alfredo,

Since your site is not live and I am having trouble with access even after updating my host file, I need to request a snapshot of your WordPress site.

To further debug the problem I’d like to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. If you prefer to do it on your own, you can provide me with the snapshot following these directions:
If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
. From WordPress plugin page, look for “Duplicator” and install it
. Once installed, you get a new main menu “Duplicator”
. Chose “Packages”
. Click on the first button you find in the toolbar on the right (“Create Package”)
. Give it a name or leave it as is
. Click on “Create Package Set”
. Wait until the package is ready
. Click on “Installer”, then on “Package”: the first one is just a php script, the second one is a zip file containing everything you need
. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)
IMPORTANT: remember to create or keep an admin account for me before creating the snapshot, or I won’t be able to login. You may delete the new admin account once the snapshot has been built.

Once the problem is resolved I will delete the local site.

August 28, 2015 at 7:03 am #691852

Alfredo

Hello Tia.
You can install and make the copy for your purpose.
Please update me asap 'cause I'm stopped and the dead line is very closed.
Regards,
Alfredo.

August 28, 2015 at 8:00 am #691943

Alfredo

Hello. Iusse solved by my self.
Thanks for your time.
Have a nice day.