This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Google not indexing translated sites Solution: Please visit WPML>>Languages, scroll down to *Browser language redirect* and check you are using *Always redirect visitors based on browser language* option. If so, it may be affecting how Google indexes your pages. Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

Visit WPML>>Languages, click on *Edit Languages* link of *Site Languages* section. Then share me the screenshot of *Edit Languages* page for a better understanding of your language settings. Relevant Documentation: https://wpml.org/forums/topic/translated-pages-are-not-indexed-by-google/#post-1529119

This topic contains 4 replies, has 2 voices.

Last updated by rusconiV 5 months ago.

Assigned support staff: Bruno Kos.

Author Posts
May 8, 2019 at 8:34 am

rusconiV

I am trying to: index my multilingual site with Yoast seo
the xml sitemap is correct but google doesn't index several page in italian and spanish
index only page in English

Link to a page where the issue can be seen: hidden link

I expected to see: the correct canonical url and the page must be indexed

Instead, I got: google doesn't index the page

what's is the problem

May 8, 2019 at 11:19 am #3765901

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you check this?
https://wpml.org/forums/topic/translated-pages-are-not-indexed-by-google/#post-1529119

"""""""""
Please visit WPML>>Languages, scroll down to *Browser language redirect* and check you are using *Always redirect visitors based on browser language* option. If so, it may be affecting how Google indexes your pages. Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/how-browser-language-redirect-affects-google-indexing/

Visit WPML>>Languages, click on *Edit Languages* link of *Site Languages* section. Then share me the screenshot of *Edit Languages* page for a better understanding of your language settings.
"""""""""

Since the site redirected me to hidden link when I opened hidden link (on the first load, later it worked well), it might be the reason why this is happening.

As for the Google itself, we have little to none effect to what will they decide to index or not.

Regards,
Bruno Kos

May 15, 2019 at 6:59 am #3812809

rusconiV

here is my language
now I check
Adjust IDs for multilingual functionality

and I check
Disable browser language redirect

Is it ok ?

May 15, 2019 at 7:52 am #3813413

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Adjust IDs for multilingual functionality

This feature turns themes into multilingual, without having to edit their PHP files and is not related to SEO or the issue here.

Disable browser language redirect

Yes, this is the path you should take, based on my reply here and other answers I quoted within:
https://wpml.org/forums/topic/wrong-canonical-url-rilevated-by-google/#post-3765901

Regards,
Bruno Kos

May 15, 2019 at 7:59 am #3813495

rusconiV

My issue is resolved now. Thank you!