This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by sarahM-17 5 months, 1 week ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 7, 2019 at 4:47 am #3753807

sarahM-17

Hi,

For Language URL format, we are using Different languages in directories.
I changed the main language from English to French and succeed. After that, I tried to change from French to Arabic. But we got the wrong directory. Instead of redirecting to ourdomain.com/ar we got ourdomain.com/fr/ar

What should we do?

Thanks

May 7, 2019 at 6:01 am #3754167

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

It seems unusual, Before diving further into the issue, I would need your help to narrow down the issue. Could you please provide feedback on the following questions as much as possible?

#1
I just noticed that you are using an outdated version of WPML plugin on your site. Since we add fixes and improvements as an update, it's quite important to update the plugin to the latest version before debugging/checking the issue.

Being so, may I kindly ask you to update the plugin to the latest version, it would also be nice if you can check the problem with the latest version and share with us the results.

BACKUP NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!). You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose. See: http://wordpress.org/plugins/duplicator/

#2
Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

#3
Could you please perform the below steps and share me the results?

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to receiving your answers so we can get to the bottom of this issue.

Thanks

May 8, 2019 at 8:36 am #3764607

sarahM-17

Hi,

This is what we got after following your step.

May 8, 2019 at 10:19 am #3765485

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for doing the tests.

To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

May 9, 2019 at 8:27 am #3774175

sarahM-17

Hi,

I'm sorry, I forgot to mention it before, but could you please enable the Coming Soon plugin? So people will know that our website is under maintenance.

Thank you very much

May 9, 2019 at 8:32 am #3774243

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just tried to quickly check your issue but it seems the login is not working, after we enter the username password it redirects to the same page.

So, could you please check it once?

Look forward to your reply.

Thanks

May 9, 2019 at 8:50 am #3774283

sarahM-17

Same for me, it's not working

May 9, 2019 at 8:59 am #3774337

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please let me know if the login was working before. It looks like a WordPress issue rather than WPML issue, so I can suggest you to try the steps suggested here: hidden link

Once the login details are back, let me know so I can fix the WPML issue.

Thanks

May 9, 2019 at 9:06 am #3774405

sarahM-17

Ok, I'll try.

Thanks

May 9, 2019 at 9:42 am #3774715

sarahM-17

Yes, it was working before.
I'll inform you later.

May 9, 2019 at 9:51 am #3774829

sarahM-17

Hi,

The login is working now,
Please use http for the url.

May 9, 2019 at 10:26 am #3775171

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

When trying to use HTTP version it redirects to https, anyway I was able to log in and when checked I couldn't find any switcher in the homepage as well as I couldn't see the Arabic translation of the homepage, so could you please help me reproduce the issue with some step to step guide?

Look forward to your reply.

Thanks

May 10, 2019 at 2:22 am #3780369

sarahM-17

Please switch to French first, after that switch to another language.
1. On the homepage please switch the language to French (we only have French translation).
2. You'll be redirected to the French homepage.
3. From the French language homepage, Please try to switch to other languages.

Our issue here is we couldn't switch to another language after we switched it to French. We will be redirected to the wrong url.

Thanks

May 10, 2019 at 3:41 am #3781163

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

You are adding the language switcher with the following code

<p> </p>
<div id="modal-ready">
    <div class="wpml-ls-statics-footer wpml-ls wpml-ls-legacy-list-horizontal">
        <ul>
            <li class="wpml-ls-slot-footer wpml-ls-item wpml-ls-item-fr wpml-ls-first-item wpml-ls-item-legacy-list-horizontal"><a href="fr/" class="wpml-ls-link" data-abc="true"><span class="wpml-ls-native">Français</span></a></li>
            <li class="wpml-ls-slot-footer wpml-ls-item wpml-ls-item-zh-hant wpml-ls-item-legacy-list-horizontal"><a href="zh-hant/" class="wpml-ls-link" data-abc="true"><span class="wpml-ls-native">繁體中文</span></a></li>
            <li class="wpml-ls-slot-footer wpml-ls-item wpml-ls-item-es wpml-ls-item-legacy-list-horizontal"><a href="es/" class="wpml-ls-link" data-abc="true"><span class="wpml-ls-native">Español</span></a></li>
            <li class="wpml-ls-slot-footer wpml-ls-item wpml-ls-item-ar wpml-ls-item-legacy-list-horizontal"><a href="ar/" class="wpml-ls-link" data-abc="true"><span class="wpml-ls-native">العربية</span></a></li>
            <li class="wpml-ls-slot-footer wpml-ls-item wpml-ls-item-en wpml-ls-current-language wpml-ls-last-item wpml-ls-item-legacy-list-horizontal"><a href="<em><u>hidden link</u></em>" class="wpml-ls-link" data-abc="true"><span class="wpml-ls-native">English</span></a></li>
        </ul>
    </div>
</div>

You are adding URLs like fr/ which is taking homeurl and changing it accordingly to hidden link so could you please replace this with hidden link and update the translations to fix the issue.

Also, instead of using direct codes as such you can also use switcher shortcodes to show the switcher, more details here: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#using-wpml-shortcodes

Let me know if this helps.

Thanks

May 10, 2019 at 4:35 am #3781329

sarahM-17

Hi,

We did nothing with that code.
We got the translation from icanlocalize but they told us that they couldn't edit any code.
Could you please check our settings? Is there something wrong with our settings?
Actually, we had another issue before. There are some broken codes after translation.
We have fixed it manually.