This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Itamar 1 year, 9 months ago.

Assigned support staff: Itamar.

Author Posts
August 16, 2018 at 2:48 pm #2650267

Sergio

I am trying to add a new translation to a new site.
aAdifferent domains per language on NGINX.

When i write the second domain in the settings, in red appears the info that the domain name is wrong.

Maybe it's a question to add a vhost the right way on NGIX.

Here is the code of the main domain:

server {
        listen 80;
        server_name <em><u>hidden link</u></em> maindomain.pl;
        rewrite  ^/(.*)$  <em><u>hidden link</u></em> permanent;
}


server {
        listen 443 ssl;

        server_name maindomain.pl;

        ssl_dhparam /etc/nginx/dhparam.pem;

        ssl_session_cache shared:SSL:10m;
        ssl_session_timeout 10m;
        ssl_certificate "/etc/letsencrypt/live/maindomain.pl/fullchain.pem";
        ssl_certificate_key "/etc/letsencrypt/live/maindomain.pl/privkey.pem";
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384 EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH+aRSA+RC4 EECDH EDH+aRSA RC4 !aNULL !eNULL !LOW !3DES !MD5 !EXP !PSK !SRP !DSS !RC4";

        add_header Strict-Transport-Security "max-age=31536000; includeSubdomains;";
        add_header Strict-Transport-Security "max-age=31536000;";

        rewrite  ^/(.*)$  <em><u>hidden link</u></em> permanent;
}

server {
        listen 443 ssl;

        server_name <em><u>hidden link</u></em>;

        root /var/www/maindomain.pl/maindomain.pl;
        index index.php;

        access_log /var/log/nginx/access.log main;
        error_log /var/log/nginx/error.log;

        ssl_dhparam /etc/nginx/dhparam.pem;
        ssl_session_cache shared:SSL:10m;
        ssl_session_timeout 10m;
        ssl_certificate "/etc/letsencrypt/live/maindomain.pl/fullchain.pem";
        ssl_certificate_key "/etc/letsencrypt/live/maindomain.pl/privkey.pem";
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers "EECDH+ECDSA+AESGCM EECDH+aRSA+AESGCM EECDH+ECDSA+SHA384 EECDH+ECDSA+SHA256 EECDH+aRSA+SHA384 EECDH+aRSA+SHA256 EECDH+aRSA+RC4 EECDH EDH+aRSA RC4 !aNULL !eNULL !LOW !3DES !MD5 !EXP !PSK !SRP !DSS !RC4";
        add_header Strict-Transport-Security "max-age=31536000; includeSubdomains;";
        add_header Strict-Transport-Security "max-age=31536000;";



        location / {
                try_files $uri $uri/ /index.php?$args;
        }

        location ~*  \.(jpg|jpeg|png|gif|ico|css|js|woff)$ {
                expires 365d;
        }

        location ~ \.php$ {
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass unix:/var/run/php5-fpm.sock;
#               fastcgi_pass 127.0.0.1:9000;
                fastcgi_index index.php;
                fastcgi_param SERVER_NAME $host;
                include fastcgi_params;
        }
}

August 16, 2018 at 6:20 pm #2651025

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thank you for contacting the WPML support forum.

You need to add the second domain to your nginx.conf file.
Foe example:

server {
        server_name second-domain.pl;
        ...
}

You can see it our documentation here.
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Please let me know if this information is helpful to you.

Regards,
Itamar.

The topic ‘[Closed] Wrong domain when setting different domain per language in the settings’ is closed to new replies.