This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 26, 2018 at 3:54 pm #2768013

feikoB

When creating a new post, in originally Spanish language, after translating to English and other the permalink is not set correct, it is shown as /?p=808.. for example.
The base language url (Spanish) is set correct to:
hidden link
But the English one is set to:
hidden link

This behaviour started from the 19th of July this Year and none of the translated posts are showing up anymore due to this issue.

We are running the latest version of WPML (4.0.7) . also installed the Sticky URL module but this has not solved the problem.

Any indication please ?

Thank you !

September 27, 2018 at 9:15 pm #2771812

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 28, 2018 at 4:36 pm #2774433

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I applied the troubleshooting options and re-saved the page, now the issue seems that disappeared.

If the issue happens again please double check if the page is in the trash.

Could you confirm that the issue is solved?

Best regards,
Carlos

September 28, 2018 at 4:53 pm #2774450

feikoB

Hi Carlos,

Thank you very much for the help, but unfortunately the issue is not fixed yet.
For the sample url the issue is fixed but for the rest of the posts (after the 19th of July) the problem is still the same.
For example, the Spanish url of the post is correct:
hidden link
But the English is not:
hidden link
Neither is the url for the CA language:
hidden link

I checked the trash and all post are deleted, which troubleshooting actions should I do to solve this? Do I have to go into each affected post to fix this ? What are the steps to fix ?

Thank you !

September 28, 2018 at 8:32 pm #2774841

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

In this case I would like to ask you to follow this steps:
- Create a full backup of the site before making any change.
- Make a bulk edit of all pages -> Save them without making any change.
- Do the same for the secondary languages.
- Go to Settings -> Permalinks -> Re-save the permalinks structure.

Could you tell me the result of the steps above?

Regards,
Carlos

September 28, 2018 at 8:49 pm #2774851

feikoB

Very sorry but not fixed still 🙁

Will show another sample of a post url not correctly working.
In Spanish fine:
hidden link
In English also ok for this post:
hidden link
BUT for the CA language the URL is not correct:
hidden link

I did all the steps you indicated in bulk and even at individual post level but with no luck so far.

Thank you for further indications.

September 30, 2018 at 2:57 pm #2776612

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

For this page I follwed this steps and the issue is solved:
- I edited the Spanish version of the post -> Manually switch languages to CA language in the admin menu -> Click on 'Edit anyways' button in the popup -> Saved the page -> Click on 'Open in Translation Editor' button in the popup -> Re-saved the translation.

Could you tell me if the issue is solved by following this steps for another page with the URL issue?

Regards,
Carlos

October 1, 2018 at 6:51 am #2777203

feikoB

Hi Carlos,

Yes, this has been solved following the steps you described, thank you!
What was causing this problem? A bug ? A wrong editing from our site ? Would be great to understand the reason.

Thank you!

October 1, 2018 at 6:16 pm #2779151

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I suspect that the cause of the issue was an interacction issue between WPML and a third party functionality. It seems that the issue is solved now because after re-saving the translation the issue disappears.

Best regards,
Carlos