This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 15 replies, has 2 voices.

Last updated by arjanB-2 12 months ago.

Assigned support staff: Bobby.

Author Posts
October 1, 2018 at 3:03 pm #2778582

arjanB-2

I am trying to: create an event in Events Maker. I have 2 lanuages: dutch (main language) and english. The event is created correctly in english. Not in dutch:
The permalink in English is "hidden link" - CORRECT
The permalink in dutch is "hidden link" - NOT GOOD!!
Can you see that in the dutch it is arjanbouw.nlevnts... It misses the "/" between "nl" and "events"

October 3, 2018 at 5:17 am #2783508

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

as a quick test please try the following

deactivate WPML String Translation plugin add-on and let me know your results

- does the permalink now work as expected ?

October 4, 2018 at 1:03 pm #2787597

arjanB-2

Hello Bobby!! Thanks for your advise! Doing this, the permalinks for "Events Maker" are created correctly, with the "right sling" on its right position. I created an event for both of languages "hidden link" and "hidden link". The permalinks were created well. There is another problem now: when I click on these links it seems that there is nothing, it seems that the links are broken or something...

October 4, 2018 at 2:27 pm #2787807

arjanB-2

By the way, I have 2 event plugins activated: "Events Maker" and also "Events Calendar". Maybe this gives you a clue. As I can see, the permalinks are generated different: now "hidden link" and before "hidden link". And another thing: if I want to edit the event created with "Events Maker" - I can see it perfectly. But if I click on the associated permalink, it fails.

October 4, 2018 at 6:52 pm #2788629

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Deactivating the String Translation is not a solution , just a quick test , unless of course you are not planning on using String Translation plugin.

but for resolving the issue please try the following

- Update plugins to latest releases;
- Remove 'Events' entries from String translation;
- Re-save Permalinks;
- In Events >> Settings > Permalinks > Events base, saved something else than 'events', then re-save again using 'events' slug;

please let me know if you are not able to perform these steps or prefer me to do so and let me know your results.

also using 2 different event maker plugins might indeed cause issues with the permalinks , have you test with just using 1 of them ?

October 4, 2018 at 8:39 pm #2788765

arjanB-2

Hi again! Thank you, Bobby for your answer! well, i need String Translation. And I need both Events Maker and Events Calendar. So, lets try to find a solution! 😉
Ok - I updated the plugins - I couldn't update the Yoast SEO - but I suppose it's irrelevant for my problem...
I activated the String Translation, in order to delete what you were mentioned. There are so many entries, I don't know what exactly I have to delete.
In Events >> Settings > Permalinks > Events base - The Events base is not "events", it is "events-maker" and this is for sure because "events" is the Events base for "Events Calendar"... well, Bobby, with String Translation activated - there is a good thing and a bad one: i created a new event in Events Maker - in english the permalink is created corectly and even more - it perfectly works when I click on it. When I create the same event in dutch (which is the default language) - the permalink is created without "/" - as I explained at the very first post.

October 4, 2018 at 8:48 pm #2788768

arjanB-2

Bobby, what about setting in WPML-Languages the option " Use directory for default language"? (I'm not sure what I have to put in the "What to show for the root url:". Maybe in this way it will be solved the "forward slash" issue will be solved...
updated: I read what's about the root url - and I don't find it an elegant solution...

October 4, 2018 at 8:49 pm #2788769

arjanB-2

I still didn't know what to delete from String Translation - there are 1.673 entries there...

October 5, 2018 at 6:08 pm #2791500

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

If possible i would like to take a closer look.

with string translation activated now you mentioned that when you create an event

instead of showing as hidden link

it shows as hidden link

correct ?

Note: what about setting in WPML-Languages the option " Use directory for default language"?

- i recommend leaving this blank for now.

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site to fix the issue.
(preferably to a test site where the problem has been replicated if possible)

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

October 9, 2018 at 7:01 am #2798476

arjanB-2

Hello Bobby,
can you send me please another request for a private message, to send you the user and pswd? thanks!

October 9, 2018 at 5:00 pm #2801307

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

private box reply has been sent

October 10, 2018 at 11:23 pm #2805977

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i am currently debugging this issue locally and i will be updating you shortly !

October 11, 2018 at 7:40 am #2806975

arjanB-2

ok, thank you!!

October 11, 2018 at 5:55 pm #2809369

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i went to WPML->String Translation->searched for "events-maker" -> and translated the string to "/events-maker" adding the slash in the front of the string and saved.

once i did that i went to the front end and i was able to view the events in Dutch as expected.

please verify with me.

Note: Make sure to clear your cache first if you are not seeing it right away.

hidden link

October 14, 2018 at 11:31 pm #2815879

arjanB-2

Hey, it's a great solution!! 🙂 🙂 tomorrow i will completely check it, before closing the thread. Thank you, Bobby!!