This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Andreas W. 8 months ago.

Assigned support staff: Andreas W..

Author Posts
February 5, 2019 at 10:23 pm #3163729

timothyM-6

I am trying to: Use the "copy to new draft" function to duplicate a translated Woocommerce product. Then I need to change a few things especially the product image. I change the product image in the en product (the default language), but in the pt-br version, it still show the product image of the original product plus the new image. The first image is the one we do not want. The second is the actual image we want to show (with the yoda and star wars content). We want it like the en product, but there is no way to get rid of the old image from the product that was copied (Here is the original product that was copied: hidden link )

Link to a page where the issue can be seen:
You can see it in action here on our site at the moment: hidden link

Use the password "gamer" to view the product (since the image is broken, we can't use the product yet.)

I expected to see:
The same image on the en product and the pt-br product.

Instead, I got: See above.

This seems similar to this issue, but no solution is given there.

February 5, 2019 at 11:09 pm #3163742

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

Thank you for contacting WPML Support.

As first step could you please increase your Memory Limit and WP Memory limit to 256M? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 64M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means,
with a default theme and not other plugins installed.

Did you translate the product with our Plugin WooCommerce Multilingual. Please try to run the troubleshoot option at WooCommerce -> WooCommerce Multilingual -> Status. You can find it at the right bottom of the page. (Option 3 - Sync Product Gallary Images)

If this will not solve the issue I would like to ask if you used our Media Translation Plugin for the task? Media Translation is dedicated for replacing images in translated contents while by default images for translated content will show a duplicate of the original content.

Could you please verify if the image was properly translated with Media Translation?

I f those workarounds will not solve the issue I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

February 6, 2019 at 10:04 pm #3167743

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

I had a look into your staging site and created two test products. I did not experience with creating, translating and replacing product images by using WooCommerce Multilingual.

I realize that there are issues when it comes to translate the product hidden link
which might be caused due to the fact that this same product has three copies. Further, I can not indicate the original product on your staging site?

Anyhow, I was able to make duplicates from my created test products, update them, replacing images and translating them again, without any issues. Please verify this on your staging site.

I would kindly ask you to complete the missing translations for WooCommerce Multilingual and please provide me exact links of the products that shhow issues with the translated images.

Screenshots:
hidden link
hidden link
hidden link
hidden link

It may be the case that your site is experiencing issues which are caused by a third plugin. I tried to recreate the issue on the staging site to troubleshoot it by disabling third plugins to see if the issue persists. It might be better if we migrate your live site to our test server as long you agree.

To troubleshoot this issue without affecting your site we can created a test server for you in Cloudways (https://wpml.org/hosting-partner/cloudways/).

Please let me know if this might be an option for you.

Kind regards
Andreas

February 6, 2019 at 10:32 pm #3167825

timothyM-6

Andreas,

We are generally opposed to hosting our site on anything but our own infrastructure. Especially given the recent lapse in WPML.org security. For now we will have to work with your access to the staging server.

I did some more experiments with other products on the staging server and did not get the same issue that happens with this problematic bxshadow copy. I told our shop manager that a solution to this problem did not look quick and that she should probably recreate the product she needs from scratch instead of using the "copy to new draft" function.

I am happy to try more on this issue later in the week to see if I can help you fix it. I need to shift focus for a day. Thanks

February 7, 2019 at 6:08 pm #3171761

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

In fact I was trying to investigate the issue starting with the mentioned product hidden link which sadly I can not locate on the staging site.

I then recreated a product with status draft. The product was translated with WooCommerce Multilingual (WCML) identically.

Please take note that in order to translate WooCommerce products with WPML please always use WooCommerce -> WooCommerce Multilingual -> Products. Product translation of products that have been created as draft will be saved as draft automatically.

I then replaced the image of the original product, saved as draft and then translated the product again with the WPML Translation Editor without any issue.

I then used the copy to a new draft function for the same product and received an identical copy for both languages.

Then I deleted the image from the original product and saved to draft. On frontend now appears the black company default logo in both languages.

I am sadly not able to recreate the issue. It would be very helpful if you could verify that and consult your translator about if the issue still persists.

It might be very possible that the troubleshooting features which I applied on WCML yesterday on your staging site solved the issue due to the synchronization of product media content.

Please let me know if you need any further assistance.

Kind regards
Andreas

February 17, 2019 at 3:35 am #3208636

timothyM-6

Well, it seems to be an issue with this product only on our site. It is an older product and I speculate that there is some old configuration conflict. I asked our shop manager to move on and I think we are going to have to let this go. I can't say it is resolved but appreciate your attention.

February 18, 2019 at 9:22 pm #3214174

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hi,

To troubleshoot this issue without affecting your site we can created a test server for you in Cloudways (https://wpml.org/hosting-partner/cloudways/).

If it is OK with you, we can migrate your content there to further debugging without any risk on your end. Please let me know if this might be convenient for you.

The copy of your site will be online, but search engines won't index it (the copy) so you don't have to worry about duplicate content.

The information you share with us will be confidential. Once the problem is resolved the details you shared with us will be deleted from our records.
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Kind regards
Andreas

The topic ‘[Closed] Wrong product images on copied product page’ is closed to new replies.