This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.04 hours from now. Thank you for your understanding.

This topic contains 25 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 22, 2019 at 11:55 am #4439037

demetrisG

Hi, I would like to know what exactly WPML does as far as the authentication part concern. As soon as I click on the Register Button in my registration form there must be some WPML hooks or functions that run right? Could you please point me to the file responsible or maybe list some hooks that are active and executed when a new user is registered?

To sum up my core problem is the following:

Submitting a registration form in English, I got a redirection to my message "Successfully registered" in Greek. It should keep the same language. Waiting for your reply.

Best regards,
Demetris

August 22, 2019 at 2:27 pm #4440345

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello Demetris,
Thank you for contacting WPML support.

1.- I suspect that there must be a configuration option to set the "Successfully registered" page in Greek. If this is the case then I kindly ask you to provide the steps to edit this option.

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

August 22, 2019 at 3:29 pm #4440815

demetrisG

Hello I have attached the debug info. The page exists in Greek and English language. I can switch between the 2 languages from the switcher at the top header. I suspect that the must be something or someone that resets the language. As I said when I register , after submitting the data the site redirects me back to the DEFAULT language (i have set the default lang through WPML settings). It does not keep the current language.

-Demetris

August 23, 2019 at 11:26 am #4446357

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Demetris,
Thank you very much for your feedback.

1.- I would like to ask you to provide step-by-step how to reproduce the issue. Attaching some screenshots will help me to have a better understanding.

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Regards,
Carlos

August 23, 2019 at 11:55 am #4446577

demetrisG

Hello Carlos,

thank you for your response. I have increased the PHP Memory Limit to 128 as you said. This did not solve my problem though. I will try to explain the issue a bit more with some steps.

1. Open up a private window (so you have no cache issues) and go to hidden link. The language should be Greek.
2. Change the language to English from the switcher at the menu bar.
3. Click at the top right button "Sign In"
4. Click at the "register" tab of the login form.
5. Fill all the information required (it doesnt matter if you are guest or owner).
6. Agree to the terms and click "Register" to submit your data.
7. I am redirected at the url: hidden link and the menu switcher is Greek language (remember that we were in english).

=> Soooo something changes or resets the language to the default value that I have set at the WPML settings.

PS. The green message "Εγγραφήκατε επιτυχώς στο Citystage" means "You have successfully registered in Citystage"

The same issue happens when you click on Lost password or even try to Sign In. So I suspect that the whole authentication part is having from problem and I hope WPML is the issue. It feels like WPML resets the selected language. :/ Any ideas?

Regards,
Demetris

August 23, 2019 at 1:01 pm #4447465

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Demetris,
Thank you very much for this detailed explanation.

In this case I will need access to the site to take a closer look at the configuration and check if there is any option to translate the redirect action after sing in.

I have set your next answer private where you will find the necessary fields to share the access credentials in a secure way.

Looking forward to your message.
Regards,
Carlos

August 23, 2019 at 1:56 pm #4447931

demetrisG

Hello again,

I have created a temporary admin login for 1 week. No username or password is required. Here is the link: hidden link

In case of any problems try a hard refresh.

Regards,
Demetris

August 23, 2019 at 7:05 pm #4449575

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Demetris,

For some reason the link you share re-directs me to this same ticket. I have set your next answer private and I kindly ask you to share wp-admin credentials so I can access to the site's backend.

Regards,
Carlos

August 26, 2019 at 9:12 am #4457037

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

This time I was able to log in the site. I took a deeper look at the issue and the problem is caused by the '[listeo_my_account]' shortcode that is in the 'My Profile' page. It seems that this functionality is not keeping the language information correctly.

I checked in our Multilingual-Ready Themes list and Multilingual-Ready Plugins list but the theme is not present nor the plugins. You can double check here:
- https://wpml.org/documentation/theme-compatibility/
- https://wpml.org/documentation/plugins-compatibility/

This means that our compatibility team hasn't validated it yet.

There are two ways to solve this issue:
1.- You contact the theme and plugin's authors and let them know about this issue so they can find a solution.
2.- I can create a test site with a fresh new WordPress installation where you can install the theme and plugins and try to reproduce the issue so I could escalate to our compatibility team.

Please let me know which option is best for you.
Regards,
Carlos

August 26, 2019 at 9:42 am #4457249

demetrisG

Hello Carlos,

I appreciate your effort. Thank you for that deep search. Sure, It would be great if we could move forward by making a copy of the website (your 2nd option) and trying to solve the issue there. Please let me know what exactly do you need from me, so I could provide all info in my next post and start the debugging procedure.

Best regards,
Demetris

August 26, 2019 at 9:54 am #4457305

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your answer.

In this case I have created a test site with a fresh new WordPress install and WPML plugins installed and setup. You can access the test site by following this link: hidden link

Please install the theme and the associated plugins and try to reproduce the issue in the site.

Could you tell me the results?

Regards,
Carlos

August 26, 2019 at 11:05 am #4457873

demetrisG

Hello Carlos,

you will find below a link to the login page. The selected language is GREEK bu the text is english (so you can understand what are you doing there). Notice that once you login as User: tester Pass: tester you will be redirected to the dashboard page in ENGLISH lang. I hope I reproduced the bug.

Login: hidden link

Regards,
Demetris

August 26, 2019 at 11:52 am #4458155

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Demetris,
Thank you very much for your feedback.

This is the expected behavior as English is the default language in the site, that's why you will get redirected to the backend in English.

However you can change the backend language by following this steps:
- Edit the profile of the 'tester' user -> Under 'Languages' select Greek -> Save the changes.

Could you tell me if the steps reproduce the behavior you expect?

Regards,
Carlos

August 26, 2019 at 2:04 pm #4459467

demetrisG

Hello,

please go to this link: hidden link. then click Register button, then click Owner tab and fill your info. Have in mind that the page is in Greek. You will notice that the message that apears after the registration is in english "You have successfully registered to Sandbox.". The message should be in Greek language "Επιτυχής εγγραφή στο Sandbox.".

I believe that now we got a bug to fix right?

Regards,
Demetris

August 26, 2019 at 2:44 pm #4459887

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I was able to reproduce the issue and applied several troubleshooting steps but the issue persists. I have escalated this ticket to our compatibility team where our compatibility specialists will take a deeper look and will try to find a solution.

In the meantime I kindly ask you to contact the theme's authors and let them know about this issue. It will be very good if you could share some contact information from the authors so our compatibility team can reach them faster.

Regards,
Carlos