This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Wrong title appear after translation

Solution: Please follow this steps: - Make a full backup of the site. - Update all outdated plugins. - Flush the cache memory. - Deactivate 'All In One SEO Pack' plugin.

Relevant Documentation:

This topic contains 7 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
February 17, 2018 at 9:19 am #1520897

aliS-7

I am trying to:
Translate a page
Link to a page where the issue can be seen:
hidden link
I expected to see:
The original title on the page that I've already set "الدعم الفني"
Instead, I got:
another title, comes from one of string translation or I don't know with name "أحدث المقالات"

However, this issue shows up for all new posts and pages, old pages and posts are working just fine, but all new post and pages keep taking this title "أحدث المقالات".
I've tried all of the support tools that available in WPML troubleshooting page, but it didn't work.

February 20, 2018 at 6:57 am #1523069

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

February 22, 2018 at 10:41 am #1526014

aliS-7

Hello Carlos,
I did that, and the issue is still there..

Regards

February 22, 2018 at 3:39 pm #1526401

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment areaa when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

February 26, 2018 at 7:26 pm #1529705

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I will make a copy of the site to make further tests on local, this way I won't affect the live site.

I will get back to you as soon as I have an answer.

Kind regards,
Carlos

February 26, 2018 at 9:12 pm #1529787

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

I have tested the site on local and the cause of the issue seems to be a conflict with the 'All In One SEO Pack' plugin.

Please follow this steps:
- Make a full backup of the site.
- Update all outdated plugins.
- Flush the cache memory.
- Deactivate 'All In One SEO Pack' plugin.

Could you tell me if the issue disappeared?

Kind regards,
Carlos

February 27, 2018 at 7:47 am #1530042

aliS-7

Thank you very much, solve it!

February 27, 2018 at 1:15 pm #1530492

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Kind regards,
Carlos