Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 16 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 6 months, 2 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 11, 2021 at 12:45 pm #8284767

vittorioP-5

Dear WPML,

I am using wpml with buddypress and mediapress. The site is both in italian (main language) and english.

Everything works fine, but when a user adds a photo to his Gallery in the english session the url for notifying the activity is wrong. Example: the url hidden link should have been hidden link

March 11, 2021 at 2:04 pm #8285649

vittorioP-5

Hello

March 11, 2021 at 2:17 pm #8285787

vittorioP-5

Hello Matteus Giulio, we are ready with backup. Are you still there?

March 11, 2021 at 4:12 pm #8287697

vittorioP-5

I still need assistance and would appreciate reconnecting to Mateus Getulio with whom I lost connection while we were at the conclusion of the chat.

Thank you

March 11, 2021 at 11:26 pm #8289565

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting our support service. I read the issue description and noticed you are having some issue with the 'member' slug translation. Can you please, let me know how can I replicate this issue in your website? Also, I would need some access details, so, I can review your settings in order find the possible cause.

The next reply is marked as private so you can safely share the access details, please, consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 15, 2021 at 3:37 pm #8312757

vittorioP-5

Dear Marcos, w are looking forward to your uppdate. If you need any other informations please feel fre to ask

March 15, 2021 at 5:57 pm #8313903

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the providede details. I tried to access your website with the provided details to give it a further look but unfortunately it doesn't seem to be correct. Can you review it please? A private reply is enabled again so you can safely resend the correct access details. Thank you for your collaboration, have a nice day.

March 16, 2021 at 12:59 pm #8321447

vittorioP-5

Hello Marcos,

any update on this issue?

Thanks
Best
Vittorio

March 16, 2021 at 6:24 pm #8325031

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I got a copy of your website using a Duplicator package and took a detailed look at this issue at my localhost, even with a default WordPress theme and all plugins disabled except WPML related ones and BuddyPress the issue persists, which makes me to believe we have a possible compatibility issue here between WPML, BuddyPress and BuddyPress Multilingual, in these cases, these are the procedures:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site, the fewer plugins the better. In your case it is possible to replicate the issue with only these plugins:

  • WPML Related ones (already provided in this sandbox install)
  • BuddyPress
  • BuddyPress Multilingual

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

March 18, 2021 at 9:10 am #8339665

vittorioP-5

Hello Marcos,

we have updated the test site with the necessary plugins and options. We have tried our best to reproduce the issue. Unfortunately we are not able to make the system generate the notification for the activity upon adding a new photo to a gallery. The issue is indeed in the notification as explained previously. The issue is easily repeatable in our site as I explained in previous message. If you can be so kind and help us just by making the system generate the notification of the activity we will complete the test site and get back to you.

March 19, 2021 at 4:33 pm #8353689

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. I will try to reproduce the issue and let you know once I am done. Thank you for your patience and understanding, have a nice day.

March 19, 2021 at 6:09 pm #8354159

vittorioP-5

Hello Marcos,

we have succeeded in making the system generate the activity notification upon adding photo to Gallery. Unfortunately we are not able to reproduce the wrong url, because the system uses "members" both for italian and english. Furthermore we have discovered that even if the page is found, the photo is not there in english, while in italian it works fine. You can test it in the sandbox with user Demo1 that we have created, adding photo in his gallery in the english version. Please give us priority as we are losing time.

March 22, 2021 at 8:07 am #8365627

vittorioP-5

Hello Marcos,

After having tested in the sandbox that you provided, we believe that there is a major bug in WPML. We are going to explain in the following what we have done and what are the results. This is what we have done:

1) We have created two users Demoit (italian user Login: Demoit CorVit11) and Demoen(english user Login Demoen CorVit11)
2) We have translated menu, pages and their belonging slugs
3) We use the latest version of BuddyPress and MediaPress. WPML is the version provided by you in the sandbox.
4) For each action done by these two users, we use different browser than the one where the Administrator (Demo) monitors the results of the activities in the Admin dashboard
5) User Demoen in english version has created a Gallery (Album Demoen2) and added thereafter a photo in it.
6) User Demoit in italian version has created a Gallery (Album Demoit2) and added thereafter a photo in it.
7) Under Activity in Admin site italian version the results for the Demoen show that the link is wrong for both UserProfile and Gallery, while the link for added photo is correct for both UserProfile and Photo.
8) Under Activity in Admin site english version the results for Demoen are all correct
9) Under Activity in Admin site italian version the results for the Demoit show the link is wrong for both UserProfile and Gallery, the link for added photo is also wrong for both UserProfile and Photo.
10) Under Activity in Admin site english version the results for the Demoit show the link is correct for both UserProfile and Gallery, while the link for added photo is all wrong.

We ask you please to solve this issue ASAP as our site is live and we its features are now stopped since we implemented WPML.
Thank you.
Best regards
Vittorio

March 22, 2021 at 7:16 pm #8371313

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details, it was very helpful to confirm the issue. It is indeed a compatibility issue which is now confirmed, it seems to come from the MediaPress plugin which is not listed as compatible with WPML at: https://wpml.org/plugin/ this is why I have escalated it to our compatibility team for a detailed investigation. I will update you here as soon as I have some more details regarding the next steps on this case.

Thank you for your continued patience and understanding, have a nice day.

March 26, 2021 at 8:54 pm #8410629

vittorioP-5

Hello,
we understand that there is a compatibility issue with Mediapress and that your compatibility team is working on it. We are puzzled that a widely used plugin as Mediapress is not in your compatibility list. Anyhow this problem is delaying remarkably our live production, and this is not acceptable for us. We therefore ask you to update us on the timing for solving this compatibility issue. Based on your feedback we might have to reconsider the usage of WPML for our multilanguage site. We are confident that you will understand our position and we await your reply as soon as possible.
Best regards
Vittorio