This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by Itamar 2 months, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
July 26, 2019 at 6:23 pm

errikosG

I am trying to: point Romanian Language on https:// clothego.ro and the English hidden link

Link to a page where the issue can be seen:
Language format URL section in WPML - whenever i add to '' different domain language and select clothego/ro it doesn't work''

I expected to see:
The translated page

Instead, I got:No change at all and at the clothego ro crashes

July 28, 2019 at 4:47 pm #4295713

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

The 'different domain per language' Language URL format option depends on correct server configurations. Please make sure that you are configuring your server correctly according to our instructions here.
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Please note that I was trying to access your site, but I've received the following error.
ERROR: Invalid username.

Regards,
Itamar.

July 29, 2019 at 11:31 am
July 29, 2019 at 4:14 pm #4301775

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Thanks the access details are working now. I accessed your site and wanted to check the issue with the homepage but it seems that you are currently editing it. Please see the attached screenshot. Furthermore, I can see that the current settings in WPML -> Languages is 'Different languages in directories'
Did you decide to change to this setting?

Also and very important for this issue. Could you please confirm that you have configured your server according to our explanations here?
https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Thanks,
Itamar.

July 29, 2019 at 6:14 pm #4302757

errikosG

sorry about that. this is how i configured my dns - check image 1
regarding the Languages is 'Different languages in directories'
no i want it on a different domain .it was a temporary action.

July 30, 2019 at 4:29 pm #4309647

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

By looking at the screenshot, it looks like it is not configured correctly. As recommended in our documentation, it is better to use the A record. I can see that you have pointed clothego.ro to 4 different IPs. Please see the attached screenshot. And I'm not sure that it is correct to do t like this. In my opinion, you should only leave the IP of the site where clothego.com is.

In addition, the CNAME is pointing hidden link to bkjfp.x.incapdns.net. This seems wrong to me. I think that it should point to clothego.ro. Please get the help of your hosting service on this issue.

If things are configured correctly on your server then when WPML is not active and in the browser, you try to get to clothego.ro you are redirected to clothego.com. When this happens, then the 'different domain per language' should work.

I've checked the settings on your site, and I could see that in the 'different domain per language' setting, it is configured to hidden link. Please see the attached screenshot www-wrong.jpg. This is also wrong, in my opinion. When I removed the WWW, it didn't help. But this because things are not configured correctly on your server. I think that your hosting service is GoDaddy. Please consult them on this issue. In my opinion, if clothego.ro is not pointing GoDaddy's server, things will not work.

Regards,
Itamar.

The topic ‘[Closed] wrong URL paths when changing languages’ is closed to new replies.