This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 3 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 4, 2019 at 1:38 pm #4143957

mikaelS-13

Hello,

when I try to import a translation job file (.xliff) it says :

The uploaded xliff file does not seem to be properly formed.

My xliff files version is 2.0 and it seems your plugin just supports until 1.2. How could I either convert the file from 2.0 to 1.2 or update the plugin in order to accept 2.0 version?

Thanks.

July 4, 2019 at 3:12 pm #4144895

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I double check our documentation and WPML only accepts XLIFF files up to v1.2: https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/

I also recommend you to visit this link where you will find more information regarding XLIFF v1.2 structure: hidden link and might help you re-format the v2.0 XLIFF files

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos