Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The button to export the XLIFF-file doesn't show up. All translations show up under "translation > jobs" and when I log in with a translator account I can see all the jobs, click and translate all fields manually. But the option to export the XLIFF-file is missing.

Solution: Go to the translator profile and check the box WPML language settings > Hidden languages: > "Display hidden languages"

This topic contains 9 replies, has 2 voices.

Last updated by Otto 2 years, 9 months ago.

Assigned support staff: Otto.

Author Posts
February 15, 2017 at 2:36 pm #1209159

katrinA-3

Hi Otto,

I have a new website but again the problem that the button to export the XLIFF-file doesn't show up. All translations show up under "translationjobs" and when I login with a translator account I can see all the jobs, click and translate all fields manually. But the option to export the XLIFF-file is missing.

I already added
define( 'WP_MAX_MEMORY_LIMIT', '256M' );
to my wp-config.

Any help is greatly appreciated!
Cheers,
Goetz

February 15, 2017 at 3:11 pm #1209215

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Goetz 🙂

I checked it locally and it's working fine for me.

Let's check first if there are any interaction issues here:
-Back up your site first
-Deactivate all the plugins that are not related to WPML
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

If the issue persists, please do the following:
-Please follow the debugging information provided here:
http://wpml.org/documentation/support/debugging-wpml/
- Repeat the action: go to the translation interface
-Copy and paste the contents of debug.log here for me to see, you may want to use pastebin.com

Let me know your results, please.

Kind Regards,

Otto

February 20, 2017 at 4:35 pm #1212836

katrinA-3

Hi Otto,

I deactivated all plugins (except for WPML of course) and switched to the twentyseventeen theme but still no XLIFF-export button. Manual translation seem to work without any problems btw.

Here's the debug: http://pastebin.com/vT79Ke7R
and here's the the communication protocol: http://pastebin.com/StNEDwAM

Cheers,
Goetz

February 20, 2017 at 6:20 pm #1212924

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello Goetz,

Thanks!

Para poder investigar mejor el problema necesitaría, si fuera posible, que me permitas acceder a tu sitio temporalmente. Mucho mejor si tuvieras un sitio de pruebas en donde esté replicado el problema.

Encontrarás los campos necesarios debajo del área de comentarios. He marcado la próxima respuesta como privada, por lo que la información que ingreses solo la veremos tu y yo.

Es posible que necesite replicar tu sitio localmente. Para eso voy a necesitar instalar un plugin llamado "Duplicator". Con él podré crear una copia completa de tu web. Una vez que el problema esté resuelto, borraré la copia local. Dime por favor si estás de acuerdo.

** IMPORTANTE **

- Por favor haz un back up completo de tu sitio y base de datos antes de proveer los datos de acceso

- Si no ves este formulario para completar los campos confidenciales NO los publiques, ya que serán visibles en el foro:
hidden link

En ese caso, pídeme que vuelva a habilitar una respuesta privada.

Muchas gracias.

Un saludo cordial,

Otto

February 22, 2017 at 1:34 pm #1214650

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Goetz,

Please apologise for that. I will reply in English this time 🙂

When you log in with an admin account you can see the export button, right?

I cloned your site locally and managed to reproduce the issue, but I couldn't do it on a fresh install.

I'm checking the problem with our second tier support, I will get back to you soon.

Thanks!

Kind Regards,

Otto

February 22, 2017 at 1:39 pm #1214653

katrinA-3

Thanks for your quick response! 🙂
I can't see the export-button at all, weather I'm logged in as a translator or as admin.
Cheers,
Goetz

February 22, 2017 at 2:04 pm #1214691

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi Goetz,

With the user you created for me I can see it. Take a look at the screenshot attached.

So you can use it to export the needed files as a workaround while we investigate the issue.

Kind Regards,

Otto

February 22, 2017 at 2:14 pm #1214711

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hi again 🙂

It seems that the problem was easier than I though.

Can you please go to the translator profile and check the box WPML language settings > Hidden languages: > "Display hidden languages"

It worked on my copy of your site 🙂

Let me know your results, please.

Kind Regards,

Otto

February 22, 2017 at 3:49 pm #1214827

katrinA-3

PERFECT! 1001 THANKS! 🙂

Sometimes the solution is too simple!

Thanks again for all your time and energy –we're happy, out customer is happy and the translators can finally start! 😀

All the best,
Goetz

February 23, 2017 at 11:27 pm #1216177

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

I'm happy to hear that, Goetz 🙂

Have a nice day!

Otto