This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I get this Fatal error when I try to export some jobs as XLIFF on WPML -> Translations page: Fatal error: Uncaught Exception: Unable to send file 'Page Name-translation-job-6.zip'. Output buffer contains the following text (typically warnings or errors):  Solution: This issue is caused by a hidden character inadvertently added in the theme's functions.php or wp-config.php file. To solve this you need to rename the old file, create a new one and paste the content of the old file inside the new one using a text editor.

This topic contains 7 replies, has 3 voices.

Last updated by maciejP-13 1 year, 9 months ago.

Assigned support staff: Vincenzo.

Author Posts
January 19, 2018 at 10:35 pm

marie-agnesH

Hello,

I am trying to: export some jobs as XLIFF on translation page

Instead, I got this error:

Fatal error: Uncaught Exception: Unable to send file 'Hérout Caves-translation-job-6.zip'. Output buffer contains the following text (typically warnings or errors):  in /home/clients/47f16ccd1c3733334275648eb354cab7/web/dev/wp-content/plugins/wpml-translation-management/inc/wpml_zip.php:481 Stack trace: #0 /home/clients/47f16ccd1c3733334275648eb354cab7/web/dev/wp-content/plugins/wpml-translation-management/classes/xliff/class-wpml-tm-xliff-frontend.php(278): wpml_zip->sendZip('H\xC3\xA9rout Caves-t...') #1 /home/clients/47f16ccd1c3733334275648eb354cab7/web/dev/wp-content/plugins/wpml-translation-management/classes/xliff/class-wpml-tm-xliff-frontend.php(111): WPML_TM_Xliff_Frontend->stream_xliff_archive(Object(wpml_zip)) #2 /home/clients/47f16ccd1c3733334275648eb354cab7/web/dev/wp-includes/class-wp-hook.php(286): WPML_TM_Xliff_Frontend->init('') #3 /home/clients/47f16ccd1c3733334275648eb354cab7/web/dev/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #4 /home/clients/47f16ccd1c3733334275648eb354c in /home/clients/47f16ccd1c3733334275648eb354cab7/web/dev/wp-content/plugins/wpml-translation-management/inc/wpml_zip.php on line 481

I noticed that if I deactivate my child theme (Basel Child) and switch to the main theme (Basel), it works.
More precisely, if I activate the child theme and remove the functions.php file (from child theme), it works.

Any idea?

Tahnk you!

January 22, 2018 at 4:40 pm #1492396

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, thank you for contacting WPML Support!
I will take care of your ticket.

It seems clear that there is some issue with the functions.php file of the child theme.

It may be something subtle like some hidden characters or a missing empty line at the end of the file.

I would suggest you comment out the second half of the functions.php file content to try to narrow down the issue. If the issue is solved you can keep reducing the commented area until you find the culprit line. If the issue is not solved, you can increase the commented area until the issue is found.

Please let me know if this helps to solve the issue or if you need further details.

Thank you

January 22, 2018 at 7:52 pm #1492726

marie-agnesH

Hello, thank you for your answer.

I already tried and retried your suggestion, without success.

Whatever I put in the functions.php file, I have the error.

I tried to put just:

<?php
?>

Or even the original content of the child theme (I mean, the one that is delivered with the template):

<?php

add_action( 'wp_enqueue_scripts', 'basel_child_enqueue_styles', 1000 );

function basel_child_enqueue_styles() {
	if( basel_get_opt( 'minified_css' ) ) {
		wp_enqueue_style( 'basel-style', get_template_directory_uri() . '/style.min.css', array('bootstrap') );
	} else {
		wp_enqueue_style( 'basel-style', get_template_directory_uri() . '/style.css', array('bootstrap') );
	}
	
    wp_enqueue_style( 'child-style', get_stylesheet_directory_uri() . '/style.css', array('bootstrap') );
}

In any case, it fails.

But if I rename/remove functions.php, it immediately works...

January 23, 2018 at 11:14 am #1493592

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

As I am unable to log in with the provided WordPress credentials, I can't do any test.

To further debug the problem I’d like to replicate your site locally.

I would need a site snapshot if possible.
We usually recommend the free Plugin “Duplicator” for this purpose.

If you already know how Duplicator works
(https://wordpress.org/plugins/duplicator/),
please skip the following steps and just send me the archive file you downloaded.

★ Duplicator Instructions
hidden link
https://wpml.org/faq/provide-supporters-copy-site/

If the file is too large (more than 200M), please use the Duplicator file filters to remove the cache, the wp-uploads directory, the media and the archive files.

Send me the archive file (you probably want to use Google Drive, DropBox, or similar services, as the snapshot file will be quite big)

Your next reply will be private, which means that only you and I will be able to see it and have access to it. You can paste the link to the file there. You can also share the credentials to your website. I will then download the file from the admin panel.
Once the problem is resolved I will delete the local site.

Let me know if you need help creating the Duplicator package.

Please add a detailed steps list to reproduce the issue.

Thank you

January 23, 2018 at 2:17 pm
January 23, 2018 at 6:47 pm #1494426

marie-agnesH

Details to reproduce:
- log in as admin or translator
- assign some translations to yourself
- go to Wpml - translations
- select at least one job
- click apply next to « export xliff 1.2 »

Then it should fail.

January 23, 2018 at 6:59 pm #1494443

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

thank you for the details, I was already working on it.

It seems like the issue is in the functions.php file itself. Most probably the cause is a hidden character.

To solve it try the following steps:

- Enter your child theme folder
- Make a backup of your current functions.php file by renaming it.
- Create a new empty file with your text editor and paste the content of your old functions.php file inside it.
- Save the new file in the child theme folder and name it functions.php

In my local copy of the site, these steps fixed the issue.
Please let me know if this solves the issue or if you need further details.

Thank you

January 23, 2018 at 7:12 pm #1494455

marie-agnesH

Yes it worked!

Thank you very much for this very good support.

In addition, I learned a new type of bug.

July 22, 2019 at 7:48 am #4254513

maciejP-13

Hi!
I have similar problem but this solution isn't work in my issues. I renamed bouth functions.php and wp-config.php next I did new file and past code form old version. Could you help me with this issues ?