Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I uploaded my spanish .xliff and they all went through. My french files however, when i upload those they say complete https://gyazo.com/d93e04f2556be958eca20de55545303a but do not actually go through. Instead it overwrites the spanish translated files. And then turns those pages to a french translation but still with the ?lang=es in the url

Solution:

Upon further inspection, we have discovered what is causing the problem: you sent the jobs to be translated to Spanish, exported the XLIFF files, translated them, and uploaded them successfully - there is no issue at this point.

However, what happened is that you also sent these pages to be translated to French, and without exporting them, translated using the same XLIFF files (and same ID) used for the Spanish in the French translation. That’s why the French content overwrites the Spanish pages.

Every exported XLIFF file contains an ID that is used to connect the translated file with its original in WPML. Once you upload the translation file, it checks for this ID and connects it to its original, regardless of the source and the target language.

So, in summary, what you need to do is to export the XLIFF files for every job in each language and translate them separately.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Mateus Getulio 4 months, 2 weeks ago.

Assigned support staff: Mateus Getulio.

Author Posts
July 1, 2021 at 6:46 pm #9114881

benG-9

Tell us what you are trying to do?
I uploaded my spanish .xliff and they all went through. My french files however, when i upload those they say complete hidden link but do not actually go through. Instead it overwrites the spanish translated files. And then turns those pages to a french translation but still with the ?lang=es in the url

Is there any documentation that you are following?
no

Is there a similar example that we can see?
hidden link

What is the link to your site?
hidden link

July 2, 2021 at 7:25 pm #9122151

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Welcome to our support forum. I'll be glad to help you!

The file may need reformatting. Please check if the formatting is correct and try to reupload it. Make sure you're following our documentation related to this subject: https://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/configuring-xliff-file-options/

Do you mind sending me the XLIFF file for debugging? Please upload to Google Drive or Dropbox and paste the private link in the private box that I'm enabling for your next reply.

Furthermore, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

July 7, 2021 at 9:25 pm #9151783

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

I checked this out but so far I couldn't find a fix for it.

I asked my colleagues to have a look at this issue in order to see if there's anything I'm missing.

I'll come back here as soon as one of my colleagues reply back to me (which it shouldn't take long).

Thanks,
Mateus.

July 9, 2021 at 12:46 pm #9165175

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello there,

Thanks for your patience while we investigate this issue.

Upon further inspection, we have discovered what is causing the problem: you sent the jobs to be translated to Spanish, exported the XLIFF files, translated them, and uploaded them successfully - there is no issue at this point.

However, what happened is that you also sent these pages to be translated to French, and without exporting them, translated using the same XLIFF files (and same ID) used for the Spanish in the French translation. That’s why the French content overwrites the Spanish pages.

Every exported XLIFF file contains an ID that is used to connect the translated file with its original in WPML. Once you upload the translation file, it checks for this ID and connects it to its original, regardless of the source and the target language.

So, in summary, what you need to do is to export the XLIFF files for every job in each language and translate them separately. Could you please give it a try now for the French pages? Let me know if these explanations are clear to you. We're looking forward to your reply.

Kind regards,
Mateus.

July 15, 2021 at 8:18 pm #9212221

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Have you been able to test the solution?

I hope we are good to close here.

Feel free to contact us any time if you need assistance with our products.

Kind regards