If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by mathieuD-2 5 years, 10 months ago.

Assigned support staff: Andrey.

Author Posts
January 17, 2014 at 9:26 am #322781

mathieuD-2

Our translation agency wants the entire website exported to an XML file for translation. After that we need to be able to import the translated XML file into the new language on the website.

Is this possible and if so, how do I do this?

Thanks!
Mathieu

January 17, 2014 at 10:50 am #322847

Gabriel

Hi, I will send you an email to discuss this. Yes we can do that.

January 17, 2014 at 10:54 am #322852

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear Mathieu,

1. You can try to use :
Tools > Export
then
Tools > Import

2. Maybe this better way is create this xml then import(convert search in web) it to XLIFF and then to WPML via WPML > Translation Management
http://wpml.org/documentation/translating-your-contents/using-desktop-cat-tools/translating-xliff-files/

You should test all options.

Thanks,
Andrey

January 20, 2014 at 2:12 pm #324152

mathieuD-2

I installed the translation management and XLIFF plugin to try it this way. I made a new translation job and e-mailed it to my own e-mail adress (including the XLIFF files) but the e-mail didn't come through and now I can't e-mail me again because the translation is already in progress.

Any way to resolve this?

Thanks

January 20, 2014 at 3:09 pm #324219

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear Mathieu,

Go to WPML > Translation Management > Translation Jobs and there try cancel job.

Does sends WordPress any emails (for example when you choose password recovery option) ?

Did you have enabled option "Use the translation editor" under Translation Management -> Multilingual Content Setup > How to translate posts and pages ? This option must be enabled for WPML to send out the translation job emails.

http://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

Thanks,
Andrey

January 20, 2014 at 3:53 pm #324272

mathieuD-2

Dear Andrey,

I was able to delete the active jobs.

WordPress sends e-mails and the 'Use the translation editor' is active but I still don't receive an e-mail.

Thanks

January 20, 2014 at 4:20 pm #324303

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear Mathieu,

Please fill in your access details below (under comment window), I'll take a look closer on your issue.

Thanks,
Andrey

January 21, 2014 at 10:27 am #324760

mathieuD-2

Details below, please keep me posted.

Thanks

January 21, 2014 at 4:45 pm #325170

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear Mathieu,

I got the details. I will take a look and update you here as soon as I know more

Thanks,
Andrey

January 22, 2014 at 8:30 am #325530

Andrey
Supporter

Languages: English (English ) Russian (Русский )

Timezone: Europe/Kiev (GMT+02:00)

Dear Mathieu,

I got the email with zip file that include XLIFF file (see attached image).

My steps:

1. Go to Users > Your profile, changed your email on my email
2. Go to WPML > Translation management > Translation Dashboard
3. Chose translator, post and language for translating
4. Clicked send documents (and got email, i sent you file that i got)

Thanks,
Andrey

January 22, 2014 at 11:37 am #325736

mathieuD-2

Dear Andrey,

I added another user and e-mail address and was able to send the translation jobs including the XLIFF files. Apparently there was an issue with my first e-mail address.

Thank you for the support.

Regards,
Mathieu