This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 3 voices.

Last updated by Andrés 5 months, 2 weeks ago.

Assigned support staff: Andrés.

Author Posts
April 17, 2019 at 1:52 pm #3631465

Adriano

Hola Andrés,

¿como estas?

I re-open this topic: https://wpml.org/forums/topic/yet-another-problem-in-translation/

The problem is that I have not added new content in my original language, the order of the contents in the translations always happens since I installed WPML.

I can't understand your advice well.

In the blog https://wpml.org/2019/04/wpml-4-2-5-greatly-improves-the-advanced-translation-editor/#comment-2112781 Amir says

"when you switch to the new translation editor, it will only apply to new translations. When you edit existing translations, you will still get the old editor." in fact I have never been able to view the old editor for existing translations

"You will not get the new editor for old translations." for any old translation I always got the new editor and in some cases they were not even complete.

Starting from 0 I believe that the new editor is much improved, but who should do the switch has only problems if in the screen of the new translation can not see the old one.

Regards,
Adriano

April 18, 2019 at 9:36 am #3637809

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Adriano!

Andrés is currently on vacation and he is coming back at the beginning of next week. I'm telling you this because I have seen that you asked for him in the other ticket, too, so in case you want me to assign this ticket to him, he will be able to answer only next week so please let me know if you want me to do that.

However, I am also happy to help if that is ok with you.

From what I can understand, you want to make sure that you fully understand what does that phrase in the link you shared means.

So practically what it will happen is that with the new WPML update, ATE (the WPML Advanced Translation Editor) will be used as default for new content - you can change that in the settings if that's not what you want - and for the translated content that was done before the WPML update, you will be able to use the same Translation Editor you used in the past - if you used the WPML Classic Translation Editor or the ATE, that's what you will be able to use going forward.

The warning that Amir is bringing into the discussion in that thread refers to the fact that in case you would like to use ATE for example for an old translation where the WPML Classic Translation Editor was used instead in the past, changing to ATE might cause issues so it is recommended to just use the same Translation Editor you used in the past (again, only for the existing translations that were there even before the new WPML update arrived).

I hope this information was helpful to you.

Please let me know if I understood your question correctly and if that helped or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

April 20, 2019 at 1:11 pm #3650293

Adriano

Hi Mihai,

unfortunately it doesn't help me because I still have problems with WPML.

1. the first sentence does not work in my case because both the old and the new translations are displayed with only the new ATE. The old translations are not translated 100% correctly and since the old translation cannot be displayed at the same time, it is difficult for me to translate 100% with the ATE method.

2. the order of the contents during the translation (both the classic and ATE) is not the same as in the original page, this complicates my translations because it's not following the logical sense of the sentences, they are not in the original sequence.

3. the original pages have not been modified for a long time, yet in the translation the contents are not in the same sequence.

4. on the translation page, using the ATE editor, it would have been useful to also visualize the translation used by the classical editor so as to be able to complete the new translation and pass entirely to the ATE editor.

5. I translated all the pages 100% in all languages, but sometimes it appears that the translation are not completed. But I have not modified the original pages in any way.

Regards,
Adriano

April 22, 2019 at 4:05 pm #3656919

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the extra information.

My colleague, Andrés, is back now and I wanted to let you know that I assigned this ticket to him as he already has insights about this particular case.

Kind regards,
Mihai

April 23, 2019 at 6:12 am #3659723

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Adriano, 🙂

I just got back from some days off.

Let's address the first issue and why your content is always displaying with ATE. Could you go to WPML > Settings and check your settings at "How to translate posts and page"? Here, you should have selected "Use WPML's Classic Translation Editor" for both, old and new content.

Please keep in mind that if you have already opened a page with ATE, you need to mark it to 100% translate in order to get back to the Classical Editor. The same happens on the other direction, you need to mark a page to 100% when it is translated with our Classical editor in order to user it with ATE.

I'll wait for your findings.

Ciao,
Andrés

April 24, 2019 at 3:59 pm #3674953

Adriano

Hola Andrés, ????

how was your holiday?

1. I have selected "Use WPML's Classic Translation Editor" for both, but in the blog Amir wrote that using the new ATE translator, for old translations is always displayed in the old method. However, by selecting ATE, I see the old translations with the new method.

2. I wish I could go into the new ATE method, much simpler, but for the pages already translated with the old method it is very complicated to be able to switch to the new one.

3. for me it is even more difficult to switch to the ATE method if there are no paragraphs in the translation or the order of translation is not progressive

4. until a few days ago the old translations were 100% in all languages, but now most are no longer 100%

Ciao,
Adriano

April 24, 2019 at 4:36 pm #3675263

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hey Adriano,

Vacations were good, but never enough! 😀

1. I have selected "Use WPML's Classic Translation Editor" for both, but in the blog Amir wrote that using the new ATE translator, for old translations is always displayed in the old method. However, by selecting ATE, I see the old translations with the new method.

I'm not sure to understand this part. However, if you choose the ATE for old content section, your already translated pages will start using ATE instead. Did I get it right? Maybe you could point me to Amir's comment for better understanding?


2. I wish I could go into the new ATE method, much simpler, but for the pages already translated with the old method it is very complicated to be able to switch to the new one.

I agree on this, but we don't have a different solution so far. :/


3. for me it is even more difficult to switch to the ATE method if there are no paragraphs in the translation or the order of translation is not progressive

WPML is guided by the use <p> or <br> to divide the content in ATE. We can investigate this in another ticket, let me know. 🙂


4. until a few days ago the old translations were 100% in all languages, but now most are no longer 100%

This usually happens when a modification is added on the original content. We can investigate this in another ticket, let me know. 🙂

Ciao!
Andrés

April 26, 2019 at 10:11 am #3689649

Adriano

Ciao Andrés,

holidays are never enough 😀😀

1. in the blog Amir wrote:
"... when you switch to the new translation editor, it will only apply to new translations. When you edit existing translations, you will still get the old editor."
"... You will not get the new editor for old translations."

But when I set the ATE method, all the old translations are displayed with the ATE method and not the classic WPML method.

2. a solution would have been to display the original text and the classic WPML translation at the bottom of the page.

3. I wish I could investigate more because in the translation page I can't understand the meaning of the sentences if I visualize them in a random way.

4. I wish I could investigate more because I haven't modified the original content in months. Last year I had translated all the pages 100% in all languages, but now they are not 100% translated.

Thanks a lot! 😊
Adriano

April 26, 2019 at 1:49 pm #3691073

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Ciao Adriano, 🙂

You are right, that shouldn't happen. Your old translations should continue using the Classical editor unless you have modify the settings for your old content. Let's investigate and start with this issue.

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behaviour?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

If you don't see the form below, pelase don't add your credentials as they will be publicly exposed:
hidden link

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

April 29, 2019 at 5:55 am #3700105

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Hello Adriano, 🙂

Thanks for your credentials.

I've visited your site and opened a page as Foto in costume which has the pencil translation icon (this implies that it has not been modified lately) and it opens correctly with our Classical Editor. Same happened with other pages as Cookie, Contatti.

However, there are some other pages as FAQ or Home which has the gear icon in some languages. This means that these translations were opened using our new ATE and until they are not marked as being 100% translated you can't use our Classical Editor. Could you please finish their translation?

Thank you for your help! 🙂

Regards,
Andrés

May 3, 2019 at 1:10 pm #3734551

Adriano

Ciao Andrés, 🙂

I have 100% translated the FAQ and Home pages in all languages.

The translation was already inserted, but for each text area there was no tick.

I still encounter the problem of text areas in unordered translations as in the original pages (1-2-3-4-5 > 1-4-3-5-2).

Also I noticed that in the WPML settings is selected "Use WPML's Classic Translation Editor" in both contents.

Regards,
Adriano

May 3, 2019 at 2:46 pm #3735615

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

¡That's great, Adriano! 😀

That means that we can move to the second issue (Translations order)? If that is the case, could you please confirm that the order issue is for the same FAQ page?

Ciao! And enjoy your weekend if you are not longer working for today.
Andrés

May 3, 2019 at 3:00 pm #3735837
Adriano

Excellent news Andrés! 😃

If I do not modify the original pages, the correct translation is inserted in the translations so why is there no longer a checkmark and it is not 100% translated?

All right, let's move on to the second issue, the order issue is for the FAQ page and the Photo in costume page. But I didn't check all the other pages.

A few more hours of work, good weekend to you too!
Adriano

New threads created by Andrés and linked to this one are listed below:

https://wpml.org/forums/topic/split-yet-another-problem-in-translation-translations-order/

May 6, 2019 at 10:36 am #3747103

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+02:00)

Perfetto, Adriano. I've opened a new ticket for continue with the translations order.
About why those pages are not marked as 100%, I really can't tell so far. The only explanation is that there was a tiny modification on the original. Otherwise, we would have to investigate it.

Let's continue with the FAQ and Photo order issues. 🙂

Regards,
Andrés