This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 month, 3 weeks ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
August 21, 2019 at 5:56 am #4428151

simchaR

Yiddish with divi theme rtl
Not displaying rtl in body in Yiddish language

August 21, 2019 at 5:59 am #4428155

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

If you disable WPML for a moment and set the default language to an RTL language, does it work properly?

Look forward to your reply.

Thanks

August 21, 2019 at 6:02 am #4428161

simchaR

Yes It is work

August 21, 2019 at 6:22 am #4428221

simchaR

Hello there,
Yes It is work fine without WPML. can you please explain what is this issue
Look forward to your reply.
Thanks

August 21, 2019 at 8:58 am #4429223

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Can you please provide a link where the issue can be replicated?

For helping further on this issue it's very important to know your site related information such as themes used, plugins used, PHP versions etc. You can easily send this using Debug information settings from WPML.

So could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

August 21, 2019 at 9:41 am #4429571

simchaR

Hello there,
Thanks for your investigation,
I have added DIVI theme in the site. RTL is not working in Yiddish language. We not installad any other third party plugin in my site. Our PHP vesion is 7.1.30.
let me know that is the issue

Look forward to your reply.
Thanks

August 21, 2019 at 10:37 am #4430295

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I think you forget to add a link where I can see the issue, can you please provide it.

Look forward to your reply.

Thanks

August 21, 2019 at 10:55 am #4430489

simchaR

Thanks for your reply
hidden link
I am working here

August 21, 2019 at 11:20 am #4430663

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there, are you talking about the test page?

Can you elaborate the issue further so I can better understand?

Also, To debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

August 22, 2019 at 4:21 am #4436231

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can replicate the issue and reported it to our 2nd tier supporters. in the meantime as a workaround, could you please follow the below steps and let me know if this helps:

- Backup your site
- Add the following code to your functions.php file

add_filter( 'language_attributes', 'language_attributes_x' );
function language_attributes_x( $output ) {
	if(ICL_LANGUAGE_CODE == 'yi') {
		$rtl = ' dir="rtl" ';
	    $output = $output . $rtl;
	    return $output;
    }
}
 
add_filter( 'body_class', 'body_class_x' );
function body_class_x( $classes ) {

    if(ICL_LANGUAGE_CODE == 'yi') {
    	
    	$key = ['rtl'];
    	$classes = array_merge($key, $classes);
    } 
    	return $classes;

}

Look forward to your reply.

Thanks

August 22, 2019 at 11:49 am #4438913

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I received feedback from 2nd tier and they provided an easy workaround, so you can follow either of these:
- Please go to WPML->String translations and find "ltr" with exact match
- Translate "ltr" to "rtl" in ST for Yiddish and save. This way you can direct plugins/themes to load RTL style.

Let me know if this helps.

Thanks