Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Marcos Vinicios Barreto 1 year, 11 months ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
August 27, 2020 at 8:34 am #6883585

guillaumeJ-4

Hello,
We are using Yoast and WPML (translation of a site from French to English) and have had many problems for the last 2/3 months. The breadcrumb was not translated and the links were pointing to wrong urls. We joined several threads on the forum talking about the problem, but the threads are noted resolved while the problem still persists, even though some points have been resolved.
Some users have opened new topics like this one (https://wpml.org/forums/topic/wrong-path-in-breadcrumb/) but we don't have answers and these don't fully answer our problems. So I take the liberty of opening a new one.
We have 2 problems:
-1st problem:
We are using WP Portfolio, and on the english archive page, the meta tag og:url always points to the french page
hidden link
instead of
hidden link
(Previously, the tag description, og:description, og:title was not translated following a Yoast update but this has been fixed with the 1.2 update of "Yoast SEO Multilingual")
On the other hand, the problem still persists with the og:url tag but we are up to date with Yoast SEO Multilingual 1.2.2.

- 2nd problem :
Moreover, we have a problem in the Yoast breadcrumb of each English page of the portfolio.
In this breadcrumb, the link to the archive page is not the right one because it is not translated and leads to a 404.
For example, on the following page: hidden link
"Achievements" in the breadcrumb leads to "hidden link; which does not exist because although there is the "/en/", "/realisations/" is the French slug ...
This should point to "hidden link;

I tried to be as clear as possible.
Our client is getting impatient. Yoast and WPML being big and widely used plugins, we assured him that the problem would be fixed soon enough but it's been almost 3 months and we're a bit worried that it's not solved yet.

Translated with hidden link (free version)

August 28, 2020 at 6:57 pm #6896075

Marcos Vinicios Barreto

Hello,

Thank you for contacting our support service. I see there are similiar reports of related issues already escalated to our developers and they are issues that seem to be fixed in the most recent versions of the 'Yoast SEO Multilingual' plugin, so, it is weird you still have such issues and it is something that definitly needs a special attention and investigation.

I would need to check your settings myself in order to understand a possible cause for such issues. For that, please consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

September 1, 2020 at 5:36 pm #6918933

Marcos Vinicios Barreto

Hello,

Thank you for the updates. I just noticed we have release a new version (1.2.3) for the 'Yoast SEO Multilingual' plugin, which seems to include fixes for the url issues. Can you test it please and let me know?

You can download it from: https://wpml.org/download/yoast-seo-multilingual/?section=changelog. Please, once updated, don't forget to resave your permalinks from your WordPress Dashboard > Settings > Permalinks as well.

Please, let me know, have a nice day.

September 2, 2020 at 12:47 pm #6925901

guillaumeJ-4

Hello Marcos Vinicios Barreto,

I just installed version 1.2.3 of 'Yoast SEO Multilingual' downloaded from the link you provided.
So it's a good step forward because it fixes the breadcrumb url problem.
It now points to the English archive page "/en/achievements/" as it should.

On the other hand, not all problems are fixed by this version 1.2.3 because the og:url tag of the English archive page still points to the French archive page.

Can you see the problem by logging in with the credentials I provided ... and report the information so that it can be fixed in version 1.2.4?
We are almost there!

Thank you in advance for everything you can do.
Have a nice day!

Translated with hidden link (free version)

September 3, 2020 at 1:56 pm #6935651

Marcos Vinicios Barreto

Hello,

Thank you for details. In order to confirm the og:url issue, we'll need to test it in a clean sandbox install, this way I can forward it as a new compatibility issue for a detailed investigation from our compatibility. In these cases, these are the procedures:

  • Install the theme/plugin in a clean installation and reproduce the problem in this new installation. So we can isolate it and do some testing without the interference of server settings or other plugins
  • After this, I will check the problem in this new installation and look for a quick solution
    If I can not find a solution, I will forward the problem to our compatibility team.
  • The compatibility team will do some more testing and will contact the product author to fix the issue

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload the (theme/plugin) to this test install, setup it the same way as in your website (using the same options) and create some dummy content to reproduce the issue. Please note that we only need the (theme/plugin) and the related functionality, you don't need to setup a entire website or clone your existing site. The fewer plugins the better.

After that, please send us clear steps on how to see/reproduce the issue on this test install. We will run some tests.

Please, let me know when you are ready, thank you for your collaboration, have a nice day.

The topic ‘[Closed] Yoast and WPML issues’ is closed to new replies.