Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Dražen Duvnjak 3 weeks, 6 days ago.

Assigned support staff: Dražen Duvnjak.

Author Posts
June 28, 2020 at 10:59 am #6469791

alainV-11

I have no translation for the category name and url in the Yoast breadcrumb. Before I update Yoast it's working like a charme... I found an solution but after saving a post modification the bug are back 🙁

I found this topic: https://wpml.org/errata/search-page-title-in-wordpress-yoast-seo-is-not-translating/comment-page-1/?unapproved=3370355&moderation-hash=2b0e1d806fec2f0d98d2f8b0c8cdc482#comment-3370355 in your forum and the workaround doesnt work for me. Now I don't know is it the same problème.

June 30, 2020 at 8:39 am #6483335

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

sorry for waiting, we have a higher queue these days.

Yes, the link shared is correct, and as you can see we have some know open issue with Yoast SEO. We are working on a new version of Yoast Multilingual that should solve most of the issues.

I found an solution but after saving a post modification the bug are back . in your forum and the workaround doesnt work for me. Now I don't know is it the same problème.

1) Can you please share what solution you used?

2) Can you please share the link and steps how can I see the issue.

Thanks,
Drazen

July 2, 2020 at 12:23 pm #6504421

alainV-11

Hi !

Thanks for you answer, for now my solution are to unchained the language article and after this i chained again the articles. After the automatique saving everything work well... But if i saved again an article for an modification le bug are back.

In this exemple you can see the category in the breadscrum are not translate :
FR: hidden link
NL: hidden link

July 3, 2020 at 6:26 am #6510735

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

thanks for the update.

If provided code example doesn't work for you, we will need to wait for new release of Yoast Multilingual that will solve most of the issue with Yoast plugin.

I will be marking this ticket as "Escalated to Compatibility team" and will notify you once we release the version that fixes the issue or we have a quick fix to provide.

Thanks for understanding and sorry for any inconvenience this issue is causing.

Regards,
Drazen

July 3, 2020 at 10:01 am #6513113

alainV-11

Thanks for the answer. i have one more question. If i downgrade yoast it's solved the problem?

July 3, 2020 at 2:30 pm #6515257

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

some of the users have mentioned reverting back to version 13.5 seems to work for them, but I haven't tested nor can confirm it. Using older version can cause some other issues.

Please make sure you have a backup if you are going to test it.

I will notify you once I have any new news on this issue.

Thanks and regards,
Drazen

July 13, 2020 at 9:40 am #6581749

Dražen Duvnjak
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hello,

I just wanted to update you, new version of YOAST ML is out that should fix your issues.

Please make sure to FIRST update YOAST SEO and then Yoast ML to avoid any compatibility issue.

Changelog: https://wpml.org/download/yoast-seo-multilingual/?section=changelog

Thanks and regards,
Drazen