This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by Bobby 8 months, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
January 3, 2019 at 11:49 pm #3054772

jorgeG-8

I am trying to: change a configuration in YOAST

Link to a page where the issue can be seen:

I expected to see: the chagnes made

Instead, I got: nothing has changed
I have desactivated all plugins but there has been no good result

January 4, 2019 at 1:37 am #3054809

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

I have reviewed the previous thread you had with my colleague , were you able to ever test this issue with a minimal environment ? if not we can set up a testing environment where we can test this without interfering with your live site

1. do you see any errors within the console while trying to save your Yoast changes ?

2. additionally I would need to see the detail of the error. You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

January 11, 2019 at 9:12 am #3079807

jorgeG-8

Ok, thanks Bobby. the issue continues.

As Your colleague told me, I disabled all the plugins, except Wpml and Yoast, and it worked wrong, I mean, I tried to change, for example, the posts titles in Yoast and while Wmpl String translations is actived It does not make any changes.

If I disable string translation, appears the change made and I can make all the changes and appear at the moment.

I have enabled the debug logging as you told me.

I have a couple of thing to ask you and I don not know if open a new ticket or wait to finish this one.

Let me know if I have to do anything in the site so you can test the issue.

thanks Bobby

January 11, 2019 at 9:06 pm #3081988

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

usually we do try to keep each ticket to 1 issue but you can ask me here that way i can see if they are related and if not we can open a seperate ticket

meanwhile i would like to take a closer look and if it is ok with you i can also create a staging site to further test this

**Before we proceed I recommend to please take FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose See: http://wordpress.org/plugins/duplicator/

I would like to request temporary access (wp-admin and FTP) to your site.

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you will enter is private which means only you and I can see and have access to it.

January 19, 2019 at 3:04 pm #3108192

jorgeG-8

I do not know if you have received my answer where I tell you the ftp and site aministrator user and password. Please let me know

January 21, 2019 at 7:52 pm #3113875

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

yes i have received the information , thank you !

i am currently reviewing this issue and update you shortly

January 21, 2019 at 8:49 pm #3114013

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for the access details !

i am currently not able to replicate the issue , if you go to YOAST which configuration are you trying to change that will not change with String Translation activated ?

if possible please provide me with the steps to replicate this issue

January 21, 2019 at 11:37 pm #3114316

jorgeG-8

Or course Bobby, theese are the steps:

SEO > Search appearance > Content types > Posts > Seo title: Here you change anything and when you save changes it appears again without ahy change done.

For example, it appears: Title - Separator - Site title - blog-2
if you change "blog-2" for "blog", for example, you save changes and when load the page again it appears again as "blog-2"

If you disable String translations, It works well, or if you make the change, disable String translations and activate again, it appears changed.

That´s all.

Thanks a lot

January 22, 2019 at 9:50 pm #3118201

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Please do the following test

Go to SEO > Search appearance > Content types > Posts > Seo title and just add anything ex. seperator -> save.

while String Translation is activated , and reload .. like you mentioned the change will not appear

now open a new tab and go to Plugins-> deactivate W3 Total Cache (keep WPML ST active) now go back to the previous tab an reload, you should see the change.

i did this multiple times and it worked , additionally i created a staging site with a clean install and i was not able to replicate this issue

there seems to be some sort of caching , when the plugins are deactivated/activated the caching clears maybe

you do have 2 drop in cache plugins

advanced-cache.php

object-cache.php

January 23, 2019 at 9:55 am #3119744

jorgeG-8

Great Bobby, thanks for your job and effort. Can you tell me please in other words what does mean: "you do have 2 drop in cache plugins "?

In other way, as I told you I have another problem that I do not know how to resolve. I need to translate the menu items and I think I am following the correct steps but It does not make any changes. (Of course I have tried it with W3 total cache desativated). Theese are those steps:

Image 1 show the menu items before translating and in english language

Image 2 go to WPML Menus sync. Here you see the items that tells me translated, For expample, "About" is not translated.
I click on Sync.
The system tells me that as I have some custom items for superior menu, I must translate them in String Translations. I go there.

Image 3: String translations page. Here you can see that I have translated "Papartus collection" to " Colección Papartus"

Imagen 4: The main page translated in spanish. Nothing changes from english version.

**********************
The last question is How can I translate the titles of the menus also?

Thanks for all Bobby and sorry for all theese problems

January 23, 2019 at 10:06 am #3119805

jorgeG-8

Theese are the images for the message I sent before. Thanks

January 23, 2019 at 6:37 pm #3122120

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

If you go to your Plugins page you can see an option that says "drop-in"

drop in plugins are usually added by cache plugins or even your server and are plugins that are activated within your wp-content/plugins folder directly , and can be seen using FTP.

For the menu, please go to Appearance->Menus-> select your primary menu and then on the right hand side click on "+" , i recommend doing it manually and not syncing the menu.

what this will do is it will allow you to create your menu for Spanish and on the left side all the Spanish translations of your pages/posts will appear

let me know your results

January 23, 2019 at 7:26 pm #3122317

jorgeG-8

Oh yeah, of course it works. Just only one thing, under "+" appears "
Synchronize menus between languages". Must I click on it?

January 23, 2019 at 8:15 pm #3122440

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I personally prefer using just the "+" translation feature, because that way i make sure i control the way the menu looks in the secondary language but of course it is personal preference 🙂

The topic ‘[Closed] Yoast do not save changes when String Translation is activated (2)’ is closed to new replies.