This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Laura 7 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
March 7, 2019 at 1:16 pm #3284641

danielD-73

Seams that theres something wrong with the Yoast meta fields. See attached image.
Our main language is Swedish. If i go to the english version of a page, and changes "allow page to be indexed by search engines" from Yes to No and hit update.

Then if i reload the english page in admin i can still see that the setting it set to No.

If i then go to the original language (swedish) and hits update (like if i have made some changes on the page). Then it seams that the "No" for search enginges i set earlier for the english page is set to Yes again because the Swedish page is set to Yes.

Also it seams that google not have indexed the swedish version at all of the site on googe if you check the index on google: site:www.clubcreo.com
But maybe thats some other problem (havent posted a sitemap yet to google)

March 9, 2019 at 9:09 am #3297490

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

Please add this snippet in WPML -> Settings -> Custom XML configuration tab:

<wpml-config>
    <custom-fields>
        <custom-field action="translate">_yoast_wpseo_meta-robots-nofollow</custom-field>
    </custom-fields>
</wpml-config>

This should solve the problem.

For the other issue, I suggest you open a new ticket. We try to have only one issue per ticket, so it's easier for others to search the forum. This also allows supporters to be faster and more efficient.
Also please consider that WPML has no way to interfere with Google, so I'm not sure we can help with this.

Let me know if this helps you or if you need further assistance.

March 11, 2019 at 8:24 am #3308331

danielD-73

Hi

I think you answered my question with another meta field. I asked for the "do not index"-field.. and you wrote "do not follow" which is the field under my marked field in the screenshot.

Anyhow, do you have all the meta fields so i can add it to the list, so i know that all the yoast fields are translatable?

Is it Yoast that need to fix there plugin to be compatible with wpml?

Also.. i cannot find Custom XML configuration under WMPL > Settings?

Best regards,
Tobias

March 11, 2019 at 11:13 am #3310071

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi Tobias,

sorry for the confusion. The right field is _yoast_wpseo_meta-robots-nofollow.

You can find all the fields in the file wpml-config file which is in the wpseo folder (that is Yoast plugin folder). Changing the values directly in this file won't work, you'll need to add them to the WPML xml-config, which is in the Custom XML Configuration tab.

This is a tab in the WPML -> Support page, please look at the image in this page: https://wpml.org/documentation/support/language-configuration-files/overriding-language-configuration-files/
If you don't have it, please let me know.

Yoast is compatible, I don't know why those fields do not appear in the WPML -> Settings page, but this doesn't mean it's not compatible, or they wouldn't add the wpml-config file.
I guess they think this kind of fields shouldn't be translated so they "hid" them to avoid people edit them by mistake.

Let me know if this helps you or if you need further assistance.

March 12, 2019 at 12:56 pm #3322261

danielD-73

This is the content of my wpml-config.xml file:

<custom-fields>
<custom-field action="translate">_yoast_wpseo_title</custom-field>
<custom-field action="translate">_yoast_wpseo_bctitle</custom-field>
<custom-field action="translate">_yoast_wpseo_metadesc</custom-field>
<custom-field action="translate">_yoast_wpseo_focuskw</custom-field>
<custom-field action="copy">_yoast_wpseo_meta-robots-noindex</custom-field>
<custom-field action="copy">_yoast_wpseo_meta-robots-nofollow</custom-field>
<custom-field action="copy">_yoast_wpseo_meta-robots-adv</custom-field>
<custom-field action="ignore">_yoast_wpseo_canonical</custom-field>
<custom-field action="ignore">_yoast_wpseo_redirect</custom-field>
<custom-field action="translate">_yoast_wpseo_opengraph-description</custom-field>
<custom-field action="translate">_yoast_wpseo_google-plus-description</custom-field>
</custom-fields>

It looks as if some of the fields is set to "copy" instead for "translate". Isnt that a strange thing? Should it be like that in Yoast and WPML for these fields?

March 13, 2019 at 12:20 pm #3333035

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

no, it's not strange. The wpml-config file comes directly from the Yoast team. Apparently, they think that fields should usually be copied instead of translated, so they set copy as default behavior.
If you want to know why they choose so, you should ask their support.

If you want to override the settings, you can just add them in the Custom XML Configuration tab and change them accordingly. Please remember that if you set them to translate, you have to manually change them every time you translate a post or page.

March 13, 2019 at 1:45 pm #3334187

danielD-73

Ok i see, thanks thats great.
Now i only have one problem left, why i cannot see the XML Configuration Tab?

March 13, 2019 at 4:20 pm #3336253

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

can you send me a screenshot of your WPML -> Setting page?

March 13, 2019 at 7:22 pm #3337797

danielD-73

Attaching how my WPML > Settings page looks like.

March 14, 2019 at 8:15 am #3341261

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

can you install and activate Translation Management and see if this fixes the issue?

The topic ‘[Closed] Yoast meta fields dont translate’ is closed to new replies.