This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by Shekhar Bhandari 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 26, 2019 at 6:48 am #3688051

sadettin-bilalS

I am trying to: Redirect old URLs to new ones by using Yoast SEO redirect table

Link to a page where the issue can be seen:

I expected to see: Redirects working

Instead, I got:

I have around 1000 301 redirects of old URLs which redirects my previous google rankings to my new WPML URLs with the Yoast SEO redirect feature. I have updated both Yoast SEO and WPML plugins yesterday, and redirects don't work anymore. I have seen the new glue plugin Yoast SEO Multilingual and installed it too.

Redirects are not working after the updates.

Redirections are saved like this, as they worked before the update

de/produkte/armstuhle/laser -> de/armchair-laser

Now, if I delete the language code from the old link it works, but acts weird redirects to English version

produkte/armstuhle/laser -> de/armchair-laser

Thats why I thought it was maybe because of WPML compatibility issue and write here

Can you help?

April 26, 2019 at 12:05 pm #3690513

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

To replicate the issue, I created a test site, you can log in with the following link [no details needed] hidden link but I couldn't replicate the issue.

So, it seems like a theme/plugin conflict or a PHP error that is blocking some functionalities and creating such issues, so could you please perform the below steps and let me know if that helps?

Minimal Setup

If you disable all non-related WPML plugins, switch to one of the default themes, the problem persists or not?

NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging

1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

April 29, 2019 at 9:40 am #3701705

sadettin-bilalS

Hello Shekhar,

I have checked the redirect section and problem is also shown here. The thing is before the updates redirect included the language code, so if we have the same slug with different languages like

/en/about - /tr/about

we were able to add different redirects for each of them, but now, the redirects do not include the language code and therefore my previous redirect data is not working, and also with this new method, I can't really redirect efficiently. how will the system know which language I'm redirecting the user to?

I have included a screenshot to show you the difference

Thanks for your help, and sorry for the delayed response

April 29, 2019 at 11:39 am #3702799

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can replicate the issue and I have escalated this issue to our 2nd tier supporters.

Our 2nd tier supporter will take a look at this issue. Once they provide any feedback, I will get back to you with that feedback here.

Thanks

May 2, 2019 at 6:25 am #3722067

sadettin-bilalS

Hi Shekhar, is there any news?

May 2, 2019 at 11:58 am #3724267

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am sorry but there isn't any update yet on this issue, our 2nd tier team is working on this issue right now.

I will update you as soon as possible.

Sorry for the inconvenience.

Thanks

May 4, 2019 at 6:12 am #3739315

arndH

Hi there,

I have a similar issue. There used to be a great workaround. https://wpml.org/forums/topic/redirecting-target-not-directly-reachable-2/
But unfortunately, this does not work anymore.

Hope you can help with a solution sometime soon.

Cheers

May 16, 2019 at 3:13 am #3821351

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Our 2nd tier supporter is working on this issue and they have found the issue when the language is used as parameter and escalated it to developers.

But currently, you are using different directories so to test the issue further, I created a new install to test this issue further, you can log in to this site using the following link: hidden link

Could you please try to replicate the issue here once? also, try to see if it's working perfectly on your install with the installed plugins versions from the sandbox. If needed please update the plugins on your live site.

Look forward to your reply.

Thanks

The topic ‘[Closed] Yoast SEO 11 with Latest WPML 301 redirect issue’ is closed to new replies.