Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: If you use the categories inside the breadcrumb, when changing the language, the link of the categories won't be translated. They will have the links from the original language.

Solution: This was fixed in Yoast SEO Multilingual 1.2.0.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by Radu 1 week, 4 days ago.

Assigned support staff: Radu.

Author Posts
July 1, 2020 at 10:58 am #6494393

alexD-34

If you use the categories inside the breadcrumb, when changing the language, the link of the categories won't be translated. They will have the links from the original language.

July 1, 2020 at 12:52 pm #6495737

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alex,

I send this issue to my colleagues, as I promised, to see if there's maybe an option that I've been missing while trying to fix this out. I will keep you posted about this as soon as I get an update from my colleagues.

Thanks,
Radu

July 1, 2020 at 1:14 pm #6495925

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alex,

I escalated this to the development team since this seems to require a closer look at the code in order to see what can we do about it and what needs to be changed.

One thing's for sure: we're gonna fix this one in order to be able to use the latest version of Yoast on your website.

Regards,
Radu

July 13, 2020 at 6:29 am #6579543

Izzi Hassan
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Please make sure to take a full backup of your website before follow any instructions.

The new version of Yoast Multilingual is available for download:
https://wpml.org/account/downloads/

Please make sure to update Yoast SEO and/or Yoast Premium first as we have had some reports of incompatibilities with older versions of Yoast, when updating to Yoast Multilingual v1.2.0.

You may need to re-save your Yoast settings after the update.

If you have any further issues, please let our Support team know here or via Chat Support and we will be happy to assist you.

Thank you and have a great week!

July 29, 2020 at 1:55 pm #6700619

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Alex,

The issue you reported was resolved with Yoast SEO Multilingual 1.2.0. We are closing the ticket but if you have any other issue you need help with, please open a new ticket.

Thanks,
Radu