This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 9, 2018 at 7:26 am

stratosK-2

I have a multilingual site (greek, english, french) and the main language is greek.

I am trying to translate the meta description for posts & pages but it doesn't work and I get the same description for every language.

I have tried to completely uninstall Yoast plugin and repeat the process using english as the base language but I get the same results.

October 10, 2018 at 2:28 am #2802646

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

1.- I would like to ask you to follow this steps:
- Install WPML Translation Management plugin.
- If the issue persists then go to WPML -> Settings -> Custom Fields Translation -> Set the Yoast description field to 'Translate' -> Save the changes.

Could you tell me the result of the steps above?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

October 10, 2018 at 7:45 am #2803221

stratosK-2

Hello Carlos,

1. I installed the plugin, used the wizard to configure a profile. Up to this point there was no change to the issue.
I followed the path but there is no option for Yoast description in 'Custom Fields Translation'

2. Done

Thank you in advance

October 10, 2018 at 10:01 am #2803743

stratosK-2

Let me also tell you that other SEO parts work fine (ex. [wpseo_titles]company_name, [wpseo_titles]title-404-wpseo, [wpseo_titles]title-search-wpseo).
The problem appears only in the meta descriptions.

October 10, 2018 at 6:47 pm #2805463

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I have been trying to log in the site to take a closer look at the issue but I can't access to the login page. Could you double check that this page is working correctly or provide the steps to log in the site?

Looking forward to your answer.
Best regards,
Carlos

October 10, 2018 at 8:02 pm #2805692

stratosK-2

Hello,

My bad, I forgot the IP restriction on. Please try again.

Thank you

October 10, 2018 at 9:10 pm #2805854

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Please follow this steps:
- Edit the homepage in the original language (English) -> Make a small change in the meta description -> Save the changes -> Translate the page.

Could you tell me if the issue persists?

Best regards,
Carlos

October 11, 2018 at 7:48 am #2807016

stratosK-2

Hi,

I can now see the field for the meta description to translate it but: 1. it is not auto generated based on the string translation 2. all the french translations are lost.

Also, when creating a new post the meta description is always in Greek.

October 11, 2018 at 9:00 am #2807239

stratosK-2

Hello again,

I just realised the problem appears only in the admin part (admin.png).

When I view source, the meta description is translated as it should.

Apparently I can finish my work (and maybe mark the task as done?) but it would be nice if I could see the proper language in the admin part.

Thank you

October 11, 2018 at 10:10 am #2807510

stratosK-2

I am gonna mark the issue as resolved as I have to deliver the site today and did the translations.

Could you please delete the screenshots as there are clients' data on them?

Thank you for your help!

October 11, 2018 at 10:11 am #2807512

stratosK-2
October 11, 2018 at 5:50 pm #2809355

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos