Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Andreas W. 4 weeks, 1 day ago.

Author Posts
July 10, 2020 at 10:47 am #6568091

oussamaM-2

I am trying to:

Set up Yoast SEO options in a multilingual website using WPML, Yoast and Yoast SEO Multilingual

Link to a page where the issue can be seen:

Staging site : hidden link

I expected to see:

The Yoast multilingual block shown in your tutorial here : https://wpml.org/documentation/related-projects/using-wordpress-seo-with-wpml/

Instead, I got:

Nothing.
I don't want to break the link between my translated pages.
I need to set up Yoast multilingual options without editing the translated page.

Thanks a lot.

July 11, 2020 at 7:55 pm #6575289

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Are you referring to the Yoast Content Meta Box, seen here?

https://wpml.org/documentation/related-projects/using-wordpress-seo-with-wpml/#%22translate-page-seo-attributes

This data should be edited on the original content only and then the page needs to be translated with our WPML Translation Editor.

We do have two options to choose from:

https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

and

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

If you do not see the Yoast content meta box please try running the site in minimal setup.

1) Disable any additional plugin that is not related to Yoast and WPML and its add-ons.

2) If the issue disappears please start reactivating the plugins one by one, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

3) Also, if this did not clarify the cause of the issue please change to a default theme like TwentySeventeen to see if the issue might be theme related, if possible.

Kind regards,
Andreas

The topic ‘[Closed] Yoast SEO Multilingual block does not appear on the page’ is closed to new replies.