This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 3 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 19, 2019 at 11:51 am #4246157

jeroenv-42

Hi,

I'm using the Yoast SEO Multilingual plugin along as well as all other WPML plugins. Yoast SEO Multilingual seems to not work at all. The English meta description and website title show up with Dutch pages (please see the attached image). This is really bad for SEO. How do I fix this?

Thanks!

July 19, 2019 at 4:43 pm #4247549

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to visit this link and follow the steps described in order to setup Yoast SEO Multilingual plugin: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Please double check if the meta description in the mentioned page is translated correctly and the page is fully translated. Also, pleas check if your sitemaps are correct too.

Kind regards,
Carlos

July 21, 2019 at 2:47 pm #4252519

jeroenv-42

Hi Carlos,

Thanks for your help. I followed the steps in that article and everything was already set up correctly.

Please see the attached screenshots.

What's the issue?

Thanks!

July 22, 2019 at 11:36 am #4256673

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I visited the site again and the meta descriptions are show correctly (see attached images). I recommend you to re-submit the site maps to Google and if the issue persists then contact their support service for a solution.

Regards,
Carlos

July 24, 2019 at 1:39 pm #4275211

jeroenv-42

Hi Carlos,

Thanks for checking the issue.
I checked Google Search Console and the sitemap was last indexed just yesterday. The meta descriptions are still not showing correctly, which is really bad for SEO and click through rates.

Is it possible this is an issue with the WPML Yoast extension? If yes, how can I fix this?

Thanks,
Jeroen.

July 24, 2019 at 2:34 pm #4275677

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jeroen,

As you can see in the attached images in my previous message the issue is not related to Yoast or Yoast Multilingual. The meta descriptions are show correctly for each language.

Please check if you ave any redirection in place and remove it, because this could cause this kind of issue.
Regards,
Carlos

July 24, 2019 at 3:01 pm #4275935

jeroenv-42

Hi Carlos,

Thanks for the quick reply. Can you please elaborate on what you mean with redirects that could cause this?

Jeroen.

July 24, 2019 at 3:05 pm #4275963

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi Jeroen,

In WPML -> Languages you can find an option to create a browser redirect based on the user's language. This option might have an impact your SEO because Google's bot will get redirected too. If you have activated this option I recommend you to deactivate it.

There other way to create redirects (plugins, htaccess, etc) that I recommend you to check. Also, contacting the support service of Google might give you a better idea why they are picking the wrong meta description for your site.

Best regards,
Carlos

July 24, 2019 at 3:29 pm #4276101

jeroenv-42

Thank you. I have deactived the browser redirect function. Hopefully it will solve this issue.

July 24, 2019 at 3:35 pm #4276147

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Thank you for your update.

Regards,
Carlos