Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Mihai Apetrei 11 months, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 10, 2019 at 12:46 pm #4730413

florinD-3

I am trying to: translate Yoast SEO into english

Link to a page where the issue can be seen:

I expected to see: the translation of the Yoast SEO plugin

Instead, I got: no possibility to translate the plugin

October 10, 2019 at 1:30 pm #4730865

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Can you please let me know if you had the chance to follow the steps in the documentation link below:
https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Also, do you refer at translating the SEO information or the plugin language in the backend?

Please let me know.

Kind regards,
Mihai Apetrei

October 11, 2019 at 9:44 am #4736907

florinD-3

Hi Mihai,
The Video I already know, so I tried to do everything but didn't work.

What do you mean with the question? I'm trying to translate Yoast on the page on the backend.

May you have a look at this? I wasn't able to certify the backup, so I couldnt give you access on the account. How can i do this then?

BR
Florin de Luca

October 11, 2019 at 3:32 pm #4740031

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Florin de Luca.

1. What I'm interested to understand is if you try to translate the Yoast SEO tags that you are manually introducing so that you can change the SEO tags on your site, or if you are trying to translate the strings that come built-in with Yoast like the normal language of the plugin, areas like "Add title" etc. - can you please answer me on this?

2. Regarding the backup, my recommendation is to use the following plugin:
- https://wordpress.org/plugins/duplicator/

Documentation can be found here: hidden link

Here is a small tutorial on how to use Duplicator:
hidden link

Please let me know when you have a backup done and then you can share the credentials with me in the private fields below.

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

October 16, 2019 at 4:36 pm #4767651

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Thank you for the credentials and the information.

I can confirm that they work.

Can you also please let me know which tags/strings have you tried to translate until now? So that maybe I can concentrate on those first?

Please let me know.

Kind regards,
Mihai

October 26, 2019 at 9:00 am #4830971

florinD-3

Hi Mihai,

I tried to translate those I have attached in the screenshot provided.

BR,
Florin

October 26, 2019 at 9:11 am #4831039

florinD-3

Hi again,

I think i cant open another ticket for some reason, so i beg you to split up what im sending you right now.

I already tried what is shown on the screenshot but nothing changed, when you search for the website the results are still in english and in german too.

Should I deactivate the Germanized plugin maybe?

Please help.

BR
Florin

October 28, 2019 at 11:49 am #4839009

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Florin.

Regarding the ticket that got closed, I am writing to my colleague so that he can reopen the ticket and get back to you - this will allow you to be able to write on that ticket again - this way, we won't have to duplicate the current ticket and create a new one.

Regarding the request in this ticket, can you please let me know if anything changed after you updated the WPML plugin to the latest version? Also, the cache plugins (wp-optimize, autoptimize) might be what is obstructing the translations that you've implemented to show up on the front-end so please try to clear the cache and disable the cache plugins and then see if the Yoast content is translated.

I will be waiting for your response.

Kind regards,
Mihai

October 28, 2019 at 12:26 pm #4839425

florinD-3

Hi Mihai,

thank you!

I tried what you just told me, but it didn't work apparently. Must be something else.

BR
Florin

October 29, 2019 at 4:14 pm #4849997

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

That is weird.

Let's try something else, too.

1. Can you please disable the "loco translate" plugin - it is not recommended that you use multiple multilingual plugins on the same site as there are issues that can appear
2. Can you please create a full backup of the site and then go here (hidden link) and update Yoast to the latest version?

Now please see if the issue is still happening.

I will be waiting for your response.

Kind regards,
Mihai

October 30, 2019 at 7:39 am #4853029

florinD-3

Hi Mihai,

I did all you said but there is nothing changing. It still looks like on the screenshots i attached.
Please have a look. There should be some possibility to translate the SEO content, but there isn't.

I don't know whats wrong there..

BR
Florin

October 30, 2019 at 10:22 pm #4859649

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the extra information and screenshots.

Today we launched some updated versions for our plugins.

Can you please create a full website backup first and then go here (hidden link) and update all the plugins to the latest version?

Please let me know if that solves the issue.

I will be waiting for your response.

Kind regards,
Mihai

November 3, 2019 at 10:14 am #4876117

florinD-3

Hi Mihai,

I did all that and it still doesn't work.. I don't know why really.

BR
Florin

November 4, 2019 at 12:14 pm #4880723

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Yes, that is super weird.

I think it would help a lot if we can recreate the issue on our servers.

I created a sandbox testing environment on the link below (one-click login):
hidden link

WPML + the WPML add-ons are already installed and I set up the same languages like the ones on the live site, all I would need from you is to install the theme and try to recreate the issue (the idea of a clean sandbox environment is to avoid as much as possible to add any other extra plugins that are not needed, so we would need just the WPML plugins and whatever is needed to recreate the issue - theme and/or plugin/s).

If the issue is going to happen on our servers, too, that's when I can forward this to our Compatibility team as I think this might be a compatibility issue after all.

Will you please let me know when that's done and what is the result so that we can move forward with this?

Thank you very much for your cooperation.

I will be waiting for your response.

Kind regards,
Mihai

November 4, 2019 at 12:34 pm #4880869

florinD-3

Hi Mihai,

I just installed the theme and set it up like my theme. Should all work!

BR
Florin