Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't Change the Yoast SEO Homepage information on a second language

Solution: The frontpage/homepage SEO setup is now done on the actual frontpage and not in the Yoast Settings as before so go to your Homepage, add your keyword (to avoid "Not available" text in SEO section) and translate your frontpage information there.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by nimoB 1 year, 10 months ago.

Assigned support staff: Alejandro.

Author Posts
November 2, 2018 at 8:28 pm

nimoB

I am trying to:YOAST SEO Premium , translate into second language not accepted. Only one language can be saved.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

November 5, 2018 at 2:17 pm #2877201

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

I'm not sure what you want to achieve so far, at the moment.
I checked your site and the products didn't have any focus keyword or anything, neither did the posts or pages.

Could you please tell me what you have tried so far, so i can check what's going on and give you a better answer?

In the meantime i suggest you read the handy guide WPML offers for Yoast SEO Translation: https://wpml.org/documentation/plugins-compatibility/using-wordpress-seo-with-wpml/

Could you please confirm that you tried following it as well?

November 5, 2018 at 5:12 pm #2877717

nimoB

first problem, YOAst in second language, works suddenly again. TExt can be saved there in second language.

2.
thing there not good:
WP Bakery module doesn't show up in the second language.
page > edit
should show WP bakery in both languages

November 5, 2018 at 6:09 pm #2877976

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, i'm glad the Yoast Issue is solved.

May I ask you to open a new ticket regarding the WP Bakery issue?

You can do it from here: https://wpml.org/forums/forum/english-support/

We can only answer one question per ticket and this one is probably not related to the Yoast Issue.

We do this to help other people with these tickets and to keep everything clean and tidy.

Once you open a new ticket you'll have the option to assign it to me, if you want to do it. I'll gladly try to solve this new issue with you.

Thanks for understanding.

November 5, 2018 at 6:58 pm #2878095

nimoB

ok, about WP bakery in another ticket.

But YOAST still not working properly:
I watched the tutorial and a video tutorial, in the first screen of Yoast > search appearance > general
ti should show below "Title Separator" "homepage" which it does not in my site.

see screenshot as it should be, and how it is at my site.

Do you know why not?

November 6, 2018 at 8:19 am #2879852

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

The frontpage/homepage SEO setup is now done on the actual frontpage and not as shown in your first image (i guess Yoast has to update its documentation), that's totally normal (it even says so in the "Homepage & Frontpage" section in the Yoast-me.jpg screenshot (and i confirmed this by installing a Yoast SEO on a local installation).

if you click the "editing the front page itself »" link, it will take you to the frontpage and you can do everything from there.

Let me know how that goes.

November 9, 2018 at 3:29 pm #2893811

nimoB

On every page in this website, YOASt SEO premium extension has been done, but in in "Publish": it says: Y seo: not availble
what does it mean?
see srceenshots of the front page.

November 9, 2018 at 5:07 pm #2894074

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

That means that your "SEO Score" is not available. that usually happens when you haven't set a focus keyword to that page.

I hope this helps, otherwise, don't hesitate to ask, i'll do my best to answer as clear as possible.

November 13, 2018 at 1:15 pm #2902734

nimoB

My issue is resolved now. Thank you!