Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bobby 11 months, 2 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 1, 2021 at 6:36 am #8886989

dominikW-15

We setup two languages (German and French) each with different URL so XXXXXX.fr and XXXXXX.com

We are currenctly using the newest WPML and newest YOAST Seo free version.

XXXXX.de/sitemap.xml works just as expected - without the .fr URLs included.
XXXXX.fr/sitemap.xml gives us a 404 error.
XXXXX.fr/sitemap_index.xml gives us the following error:
Unsafe attempt to load URL hidden link from frame with URL hidden link. Domains, protocols and ports must match.

Steps to reproduce:
1. Setup a new wordpress installation
2. Install all WPML Plugins
3. Install the free YOAST Seo Plugin
4. Setup two languages and set them to use different domains per URL
5. Look at the sitemap.xml of each language
--> only the default language sitemap.xml is accessible

Thanks for your support
Dominik

June 1, 2021 at 5:30 pm #8892495

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the above explanation!

With different domains per language, you should be able to access the sitemap under the different domains.

if possible, please verify that the DNS has been set up correctly as explained here:
https://wpml.org/documentation/getting-started-guide/language-setup/language-url-options/how-to-use-wpml-with-different-domains-per-language/

June 1, 2021 at 6:13 pm #8892633

dominikW-15

Yeah we've setup everything correctly - I think otherwise we would not be able to switch the language and see the correct content.

The only issue is the sitemap - I think that wpml reads the default domain for loading the sitemap url stylesheet and not the url that the user is currently browsing - because of that Google Chrome throws the error:
Unsafe attempt to load URL hidden link from frame with URL hidden link

Have you tried it in your setup - it is really easy to reproduce.

June 1, 2021 at 7:48 pm #8893051

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I have not been able to reproduce it on my side.

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed It is necessary to take FULL BACKUP of your database and your website. Providing us with access, you agree that a backup has been taken **

I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/
You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

June 2, 2021 at 5:02 pm #8901601

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Thank you for updating us with the above results.

We have contact with their compatibility team, however, they would most likely resolve this much faster if it was reported directly to them by a user.

The topic ‘[Closed] YOAST SEO sitemap not loading’ is closed to new replies.