This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 3 voices.

Last updated by alexanderA 1 year, 4 months ago.

Assigned support staff: Otto.

Author Posts
May 17, 2018 at 9:03 am #2170696

alexanderA

Hello. My site is in English and I want to add a Chinese translation. I duplicated my page from EN into CN, and the CN page displays an error, "Your theme’s template file for displaying Page items is missing custom fields." My EN page does not display this. (see attached screenshots for comparison between EN and CN page). How can/should I resolve this?

Thanks.

May 20, 2018 at 11:11 am #2196649

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please, apologize for the delay in answering. We are a bit loaded lately, but working hard to get back to normal. Another colleague will take care of the ticket as soon as possible. Meanwhile, I would like to provide some hints and debugging steps to move things forward.

First, please check if the custom fields were set to "translate" or "copy":
WPML > Translation Management > Multilingual content setup > Custom fields

if not, set them to translate and duplicate the pages again.

Also, check this documentation, please:
https://toolset.com/documentation/translating-sites-built-with-toolset/translating-content-templates-wordpress-archives-views-cred-forms/

Let us know if this points you in the right direction, please.

Kind regards,

Otto

May 20, 2018 at 11:29 am #2196651

alexanderA

Thanks for the reply. I read through your suggestions, but unfortunately I'm still a bit confused.

>> First, please check if the custom fields were set to "translate" or "copy":

I'm not sure which custom fields you mean. WPML > Translation Management > Multilingual content setup > Custom fields contains several hundred custom fields.

>> Also, check this documentation, please:
https://toolset.com/documentation/translating-sites-built-with-toolset/translating-content-templates-wordpress-archives-views-cred-forms/

I don't understand why you are linking me to a page for Toolset Types. I thought I was experiencing a WPML issue.

Thanks.

May 21, 2018 at 8:27 am #2199525

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I will help you further on this issues.

I would like you to go to WPML > Translation Management > Multilingual content setup > Custom fields and mark those fields as translate which is associated with the posts. Either way, you can go to the page editor in the default language and under "Multilingual content setup" you can mark those fields as translate too.

The reason behind Otto provided you a Toolset documentation is because the issue is happening with Toolset + WPML, so could you please check the documentation and see if that helps?

Look forward to your reply.

Thanks

May 21, 2018 at 11:12 am #2200754

alexanderA

Thanks very much for the reply--I appreciate your help. But I am still very confused as to what is occurring, and how to fix it. Hopefully you can explain it in a more basic fashion.

>> I would like you to go to WPML > Translation Management > Multilingual content setup > Custom fields and mark those fields as translate which is associated with the posts.

I'm sorry, I don't understand what you are asking me to do. I have opened WPML > Translation Management > Multilingual content setup > Custom fields. There are several hundred custom fields here. What exactly should I do now?

> Either way, you can go to the page editor in the default language and under "Multilingual content setup" you can mark those fields as translate too.

I'm not sure what this means either :-/

All I am trying to do is create a duplicate (Chinese language) of one particular page--my home page. A few months ago I did the same thing, only I created a French language duplicate. I don't recall having this issue at that time. Why is this occurring? Is resolving this issue necessary? What happens if I ignore this message?

Thanks.

May 22, 2018 at 2:50 pm #2209127

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please provide me your login details so I can show you screenshots or video to follow the steps properly?

I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

May 23, 2018 at 11:22 am #2214904

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I consulted this issue further with other support member and they mentioned that It’s just a notice that tells you, the Theme File is not holding any call to that Custom Field, hence, it will not display it.

You can either adapt your Theme’s Files according to this https://toolset.com/documentation/customizing-sites-using-php/ or insert the Field with the Types GUI into your Post Body Editor.

Also, I would request you to check if those fields are displaying properly on the front-end in spite of the messages?

Look forward to your reply.

Thanks.

May 23, 2018 at 11:34 am #2214912

alexanderA

Hi Sekhar,

Thanks for your help so far. But I have to be honest, I am not understanding any of what you are telling me, and I'm afraid much of it is because of a language barrier. The English you are using has a lot of errors, and it is difficult to understand your instructions/explanations. With this matter, it is very crucial that I understand everything very carefully. Is it possible to transfer me to another agent that can perhaps articulate these details a little better? I'm sorry, it is nothing personal, but I really need to make progress on this. It has been nearly a week now and I am still where I was when I first started 🙁

Is it possible for you to transfer me to Otto? I typically have good success understanding him.

Thanks.

May 23, 2018 at 4:59 pm #2217053

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello again 🙂

I will do my best to explain the issue here.

Your site is using the Toolset plugins. That allows you to create custom fields for posts, pages or custom post types.

The warning just says that there are some custom fields for that page which are not displaying in the template (so those custom fields of that page won't appear on the front end IF the warning is right)

This is perfectly fine, many times you want to have some custom fields for other purposes than to show them on the front end.

But, as it is working on the default language, it will probably be working fine in the secondary language.

So, if the front end is working as expected, there is nothing to worry about the warning.

Now, why you are seeing the warning just on the Chinese page you are wondering, right?

It may have been an issue when duplicating the page.

I suggest two tests:

First, duplicate another page to Chinese and check if the issue persists.

If it doesn't, duplicate again the home page (take into account that this will overwrite the translation if you already made it).

To do so, go to WPML > Translation Management > Select the page and at the bottom choose duplicate for Chinese and do nothing for the other languages.

Then check the Chinese page again, does the warning persists?

Please, let me know if my explanation was clear enough and how the tests went.

Kind regards,

Otto

May 24, 2018 at 6:36 am #2219846

alexanderA

OK thanks for that. It is becoming clearer.

>> Now, why you are seeing the warning just on the Chinese page you are wondering, right?
>> It may have been an issue when duplicating the page.
>> I suggest two tests:
>> If it doesn't, duplicate again the home page (take into account that this will overwrite the translation if you already made it).

I want to do this.

>> To do so, go to WPML > Translation Management > Select the page and at the bottom choose duplicate for Chinese and do nothing for the other languages.

Before I do this, in Translation Management, when I select the page and scroll to the bottom, there is an additional section for "French." What should I set it to: Translate, Duplicate content, or Do nothing? This particular page is already translated into French, and I do not want it to be overwritten. So I guess I should select "Do nothing" for French--is that correct?

Thanks.

May 24, 2018 at 11:30 am #2222257

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Exactly.

Select "Duplicate" for the language you want to overwrite. And "Do nothing" for the language you want to keep.

As always, please backup your site before trying any suggestion.

Let me know how it goes, please.

Did you try duplicating another page? Did the issue happen on that page too?

Kind regards,

Otto

May 24, 2018 at 11:45 am #2222277

alexanderA

>> Select "Duplicate" for the language you want to overwrite. And "Do nothing" for the language you want to keep.

OK I tried that, and duplicated the page to CN, but the same issue occurs. Again, this error message does not appear on my EN page, nor on my FR page (which also began as a duplicate of the EN page). Any ideas why this is occurring?

>> Did you try duplicating another page? Did the issue happen on that page too?

No I haven't. The main reason is that because I *know* the home page displays some custom fields via Toolset Types, and I'm not sure if that's true for any other pages. Would it be helpful if I tried duplicating another page?

Thanks.

May 24, 2018 at 6:15 pm #2224969

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

There is a hiccup when duplicating the home page. Something is not being updated properly.

As mentioned before, if the page is displaying properly, the problem is with the check that Toolset makes. So it is just a false positive.

To get more information about what may be the cause of the problem, can you please try the following:

1.
Enable the WP debug mode. To do it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

If you can paste your debug.log to pastebin.com and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

2.
Then, run the update of the page again (the same test as before, but this time if there is any error it will be logged)

3.
Go to Pages, switch to Chinese and delete the Chinese homepage.

Empty the trash.

Duplicate the home page again to Chinese.

Let me know your results, please.

Thanks for your cooperation!

Kind regards,

Otto

May 25, 2018 at 10:39 am #2228472

alexanderA

OK. I just want to be clear on the instructions:

>> 2.
Then, run the update of the page again (the same test as before, but this time if there is any error it will be logged)

I'm not sure what you want me to do in this step, are you saying I should refresh the page?

May 25, 2018 at 3:34 pm #2230619

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please apologize I wasn't clear enough.

After enabling the WP debug mode, please do this again:
Go to WPML > Translation Management > Select the page and at the bottom choose duplicate for Chinese and do nothing for the other languages.

This time, if there is any error while duplicating the page, it will be logged.

Let me know your results, please.

Kind regards,

Otto