This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bruno 5 years, 7 months ago.

Assigned support staff: Bruno.

Author Posts
December 3, 2014 at 4:43 pm #522607

alexandre

I am trying to: Move from a beta site to its production site; copied the DB and the folder structure, configured DB access, but on the productions site I get this message:

Your WPML settings seem to be corrupted. To avoid corrupting your existing data, we have hidden WPML from this site.

If this is the first time you install WPML on this site, you may have faced a database or script connection drop, that caused settings to be not completely store.In this case, you can click on the Reset Settings button: this will reset WPML settings and any language translation information, allowing you to restart the wizard.

If you have just upgraded WPML or after starting over you keep getting this message, please contact the support forum as soon as possible, in order to provide you with a fix to this issue.

thanks a lot

December 3, 2014 at 11:06 pm #522777

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I'll ask for some information so I can verify the problem. The fields for you to insert the credentials will be below its comment field.

Please let me know exactly what steps should I follow to see the problem. Also, please let me know what is the default language of your website.

Note: Please make a full backup of your site.

Thank you.

December 4, 2014 at 7:08 pm #523385

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Unfortunately my IP is dynamic and it changes very often. Maybe I do not need FTP. If possible, you could allow access to Brazil (where I am located)?

Also, what is the default language of your website?

Thank you.

December 4, 2014 at 10:39 pm #523456

alexandre

Default language is set to Italian.

December 5, 2014 at 12:12 pm #523789

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I was checking the problem on your site, but now the credentials are no longer valid.

This error message is displayed:

ERRORE: Nome utente non valido. Hai perso la password?

I did not see the error message that you mentioned on the topic. It seems that the WPML is working properly.

Please could you check if it is working as desired?

Thank you.

December 5, 2014 at 1:33 pm #523854

alexandre

Just checked the login I gave you and it works for me.
Once logout in I still get the message:

Your WPML settings seem to be corrupted. To avoid corrupting your existing data, we have hidden WPML from this site. ..... See also the screenshot

December 5, 2014 at 5:43 pm #524013

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I fixed your site. Please could you check if it is working as desired?

For your information. I do exact steps:

1, Backup your database via Adminer.
2, Open file footer.php in your theme folder. I used the theme editor ( Appearance > Editor ).
3, Add this snippet to the end of footer.php ( before the </body> end tag ). Note: because your default language is Italian, with the code 'it' , I set it instead of 'en' in the line

$sitepress->set_setting('default_language', 'it'); // <----- MAKE SURE TO KNOW WHAT'S THE WEBSITE DEFAULT LANGUAGE BEFORE DOING SO!!!!

<?php
global $sitepress;

$setup_complete = $sitepress->get_setting('setup_complete');
$default_language = $sitepress->get_setting('default_language');

if(!$setup_complete) {
    $sitepress->set_setting('setup_complete', 1);   
}

if(!$default_language) {
    $sitepress->set_setting('default_language', 'it');    // <----- MAKE SURE TO KNOW WHAT'S THE WEBSITE DEFAULT LANGUAGE BEFORE DOING SO!!!!
}
$sitepress->save_settings();
?>

4. Save file footer.php
5. Run your homepage
6. Delete the snippet.
7. Go to WPML -> Languages and configuration your default language with Dutch.

That's all.

Thank you.

December 10, 2014 at 9:56 am #526082

alexandre

Hi,

this worked nicely! Thanks very much!

The only remaining issue we have is that the plugin: WPML Multilingual CMS (3.1.8.4)
does not appear in the Sites lists under hidden link

Plugins which are installed via the WPML plugin appear in the site lists.

thanks again for your help

December 10, 2014 at 2:51 pm #526329

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Glad to hear that it now works. As the original issue is resolved may I kindly ask you please to open a new ticket for your new question? This will also help other users with similar problems find solutions when searching the forum.

Thank you.