This thread is resolved. Here is a description of the problem and solution.

Problem: Yslow is reporting a redirect on the homepage to itself.

Solution: The reported redirect was showing the URL without the trailing slash redirecting to the homepage with the trailing slash. This ended up not being WPML related.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by thierryN-5 1 year, 7 months ago.

Assigned support staff: Lauren.

Author Posts
October 9, 2018 at 8:19 pm #2801946

thierryN-5

Hi

It is not a big deal, but when I test the english version hidden link with Yslow, they find a redirection from this homepage to itself...

I checked:
- .htaccess
- my redirection plugin

and I did not find anything.

Is it a bug in Yslow or something else?

Best and kind regards
Thierry

October 10, 2018 at 2:33 pm #2804834

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

It looks like the redirect is going from http to https. I checked it on hidden link and found this:

Checked link: hidden link

Type of redirect: 301 Moved Permanently

Redirected to: hidden link

Looks like the homepage is loading correctly for me. Are you seeing any issues with the homepage loading?

October 10, 2018 at 5:14 pm #2805291

thierryN-5

Hi Lauren

Thanks for your answer.

I know that all http traffic is redirected to https

My question was about:

hidden link redirects to hidden link

that is mentioned on Yslow report on GTMatrix

There is no trailing / in the first URL that is redirected to the URL with a trailing /
I should have been more precise, sorry.

In fact, every URL without a trailing / is redirected to a URL with the trailing / So WPML is not involved with this.

Sorry for losing your time on a no-problem.

Best and kind regards
Thierry

October 10, 2018 at 5:15 pm #2805294

thierryN-5

My issue is resolved now. Thank you!