Sauter la navigation

Open

Reported for: CMS multilingue de WPML 4.6.6

Topic Tags: Compatibility

Overview of the issue

When utilizing the Elementor plugin and translating background images using WPML Media Translation, if these images are configured as a slideshow for a section, you may encounter an issue where they do not appear translated in their respective translated versions.

Workaround

Please, make sure of having a full backup of your site before proceeding.

  • Open …/wp-content/plugins/sitepress-multilingual-cms/addons/wpml-page-builders/classes/Integrations/Elementor/media/modules/AllNodes.php file.
  • Replace:
    		foreach ( $backgrounds as $background ) {
    				$settings = $this->translate_image_property( $settings, $background , $target_lang,
    					$source_lang );
    		}
    
  • For:
    		foreach ( $backgrounds as $background ) {
    				$settings = $this->translate_image_property( $settings, $background , $target_lang,
    					$source_lang );
    		}
    
    		$settings = $this->translate_images_property( $settings, 'background_slideshow_gallery', $target_lang, $source_lang );
    

Laisser une réponse

Please stay on topic and be respectful to others. If you need help with issues not related to this post, use our Support Forum to start a chat or submit a ticket.

Vous pouvez utiliser ces balises :
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>