Skip Navigation

Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe du WPML répond sur le forum 6 jours par semaine, 22 heures par jour.

This topic contains 7 réponses, has 2 participants.

Last updated by Andrés Il y a 7 mois et 2 semaines.

Assigned support staff: Andrés.

Auteur Messages
février 15, 2022 à 7:22 #10580401

P-Derathe

Bonjour
J'ai installé
WPML Multilingual CMS
WPML String Translation
WPML Media
les versions sont à jour

J'ai créé 3 photos de test
nagesh-badu-nSn5Labyy-M-unsplash.jpg
daniel-tseng-QCjC1KpA4nA-unsplash.jpg
aaron-burden-5c5VcFshOds-unsplash.jpg

Pour chacune de ces photos j'ai crée les métadonnées dans 3 langues : FR EN et ES

J'ai créé deux articles de test
Article test 1 FR
et Article test 2 FR
l'outil de traduction
hidden link
m'indique que ces deux articles ont été correctement traduits... Mais il ne m'a pas demandé de traduire le corps du texte de l'article. Ce qui fait que quand je visualise l'article en Anglais ou en Espagnol le texte est en Français
Idem pour les metadonnées des photos Voir la photo à gauche du texte et les 3 photos de la galerie au suvol) :
hidden link version FR
hidden link et hidden link les textes du contenu sont en français "Ceci est un article de test n°1"

j'ai modifié l'éditeur de traduction comme vous me l'indiquiez pour passer avec "WPML / Paramètres / Éditeur de traduction avancé (recommandé)"

Je pensais avoir tout fait correctement mais visiblement ce n'est pas ça

J'ai effacé mon article test #3 et l'ai recréé dans BETheme:
-- une image à la une
-- Un titre "Article test #3 FR"
-- un bloc de texte avec une image (la même que l'image à la une) en format 300px de large et un peu d etexte en français et du Lorem ipsum
-- une galerie de trois photos BeTheme : chacune de ces 3 photos ayant ses metadonnées traduites avec WPML
L'article en question :hidden link

J'ai donc ensuite initié la traduction en anglais en allant à 100 de traduction. Bizarrement le bloc de texte avec l'image à gauche n'a pas été présenté à la traduction cf image 220202-trad-art-3.jpg

J'affiche donc l'article traduit hidden link

Fort logiquement le bloc de texte n'est pas traduit Cf. 220202-art-3-en.jpg

Et les métadonnées des photos que ce soit dans le bloc de texte et la galerie ne sont pas traduites (passez la souris sur les image de la galerie, les "captions" apparaissent en Français)

Il manque le contenu de l'article (au sens de l'éditeur de Worpdress/Betheme) (cf. la capture 220208-stjsosep-editeur-contenu-article.jpg)
Ce texte que vous voyez sur la capture d'écran de l'article en FR hidden link (220208-article-3-FR.jpg)

Je peux vous donner un accès admin si vous me proposer une réponse en privé

Merci pour le coup de pouce

Cordialement

Pascal

220208-article-3-FR.jpg
220208-stjsosep-editeur-contenu-article.jpg
220202-art-3-en.jpg
220202-trad-art-3.jpg
février 16, 2022 à 7:14 #10590379

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Pascal,

Bienvenue à l'assistance technique de WPML.

Par rapport à nos règles de support, nous devons gérer un seul incident par ticket, ça nous permet d'améliorer notre service et permet à d'autres utilisateurs de bénéficier des informations exposées.

Commençons avec la traduction du texte, une fois ce problème a été résolu nous allons investiguer la traduction des images.

Or, dans une page de test :
- Ajouter uniquement un bloc de texte comme celui qui vous n'arrivez pas à traduire.
- Traduisez la page.
Est-ce que le bloque est present cette fois dans ATE ( Advanced Translation Editor ) ?

Cordialement,
Andrés

février 16, 2022 à 8:31 #10590943

P-Derathe

Bonjour Andres
Cela faisait bien longtemps que je n'avais pas eu a faire avec vous.

J'ai donc créé une page de test assez simple hidden link

avec un bloc de Titre "Ceci est une page de test"
et un bloc de texte avec une image alignée à gauche et le texte "Ceci est un bloc de texte avec du texte en Français à des fins de test du traducteur WPML.

Je n’ai pas grand chose à indiquer ici si ce n’est que ceci sera à traduire en Anglais et en Espagnol."

Ensuiet j'essaie de traduire cette page en Anglais.
Le traducteur de WPML ne me montre pas les contenu des blocs Titre et Texte à traduire
Cf. la capture 220216-ecran-de-traduction-de-page-test.jpg

et donc la page en Anglais ... n'est pas traduite : hidden link

Si vous souhaitez un accès admin ; OK pour moi. Demandez.

Cordialement

Pascal

220216-ecran-de-traduction-de-page-test.jpg
février 16, 2022 à 11:38 #10592517

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre retour. C'est vraiment bizarre que la traduction d'un texte si simple ne fonctionne pas avec un thème compatible comme Betheme.

Pour pouvoir diagnostiquer cette issue sans impacter votre site en ligne, et éventuellement pour solliciter notre équipe de compatibilité, j'ai créé un serveur de test, la majorité des extensions nécessaires sont déjà installées. Veuillez utiliser le lien suivant pour vous connecter.
hidden link

Une fois vous êtes sur le Bureau du site, installez uniquement votre thème et essayez de reproduire cette situation.

Note: vous n'avez qu'installer le thème nécessaire pour reproduire votre problématique. N'installez pas une copie de votre site.
https://wpml.org/faq/how-to-reproduce-issues-and-share-them-with-wpml-support/

Cordialement

février 16, 2022 à 4:14 #10595771

P-Derathe

re-bonjour Andres
Quand je fais le test avec Betheme installé et le chikld-theme de Betheme actif sur
hidden link

l'éditeur de WPML voit bien les champs de l'éditeur de texte de BeTheme cf image jointe
Alors que sur hidden link
l'éditeur de theme de WPML ne me les propose pas

220216-editeur-texte-page-test.jpg
février 17, 2022 à 6:41 #10599877

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de votre retour. Par contre, je vois des différences dans les captures d'écran :

1. Dans votre site vous utilisez l'éditeur WPBakery Page Builder mais pas dans le site de test. Utilisez-vous un shortcode en particulier ? Pouvez-vous rajouter cette extension ?

2. Vous utilisez l'éditeur Avancé mais vous avez mis le Classique dans notre site. Je l'ai mis aussi finalement.

3. Dans votre site de test vous rajoutez des images dans le bloque de texte mais pas dans notre site. Est-ce que si vous enlevez l'image le contenu est traduisible ?

J'attends vos commentaires.

février 17, 2022 à 1:45 #10603957

P-Derathe

Bonjour Andres

Effectivement je n'avais pas fait attention au fait que sur hidden link j'utilisait WPBakery en plus de Bethemes

Sur hidden link je l'ai donc installé et j'ai aussi ajouté une photo dans l'article hidden link Ici la traduction des blocs de texte et des metadonnées des images semble bien fonctionner.

Je ne comprends pas ce qui ne va pas dans hidden link

Cordialement

Pascal

février 18, 2022 à 6:49 #10608927

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Pascal,

Dans ce cas, vérifions s'il existe une incompatibilité avec une autre extension :
Dans votre site de test, est- ce que vous pouvez vérifier si cette situation arrive quand:
- Seulement le paquet WPML est activé. Cela va nous dire s’il y a un problème d’interaction avec une autre extension.
- Vous changez votre thème enfant pour le thème paren. Cela va nous dire s’il y a un problème d’interaction avec votre thème enfant.
- Vous changez votre thème pour un thème par défaut de WordPress. Cela va nous dire s’il y a un problème d’interaction avec votre thème.
- Si le problème disparait, est-ce que vous pouvez commencer à les activer, un par un jusqu'au problème revient ?

Cordialement