Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Aucun de nos assistants n'est disponible aujourd'hui sur le forum French. Veuillez créer un ticket, et nous nous le traiterons dès notre prochaine connexion. Merci de votre compréhension.

This topic contains 17 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 1 mois.

Assigned support staff: Andrés.

Auteur Messages
octobre 5, 2018 à 1:07

ludovicG-3

Bonjour, pour certains de mes produits traduits en anglais ou en allemand, l'ajout au panier n'apparait pas dans la fiche produit.

Pouvez-vous m'aider s'il vous plait ?

Une des URL de mon site Internet où le problème apparaît : hidden link

Je m'attendais à voir : apparaître la possibilité d'ajouter au panier

À la place, j'ai obtenu : l'ajout au panier n'est pas visible

octobre 5, 2018 à 3:53 #2791235

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Bienvenue à l'assistance technique de WPML.

Je viens de visiter votre site et je vois que le problème arrive avec un produit en bundle.

1. Est-ce que ce problème arrive uniquement dans ce produit ?

2. Est-ce que si ce problème arrive dans des autres produits, il s'agit des produits en paquet aussi ? Cela nous permettre comprendre si le problème est lié à l'extension WooCommerce Product Bundles.

3. Pouvez-vous incrémenter votre MemoryLimit et votre WP Memory Limit jusqu'à 640M car je remarque un ralentissement dans votre site ?
Vos valeurs actuelles sont:
- MemoryLimit 640M
- WP Memory Limit 256M
https://wpml.org/home/minimum-requirements/

- Éditez votre fichier wp-config.php et ajoutez la ligne suivante :

define('WP_MEMORY_LIMIT', '640M');

Cordialement,
Andrés

octobre 5, 2018 à 5:00 #2791381

ludovicG-3

Bonjour Andrés, merci pour votre réponse.

J'ai modifié le wp_memory_limit à 640M.

Le problème également à deux autres produits :

hidden link
et hidden link

Tous les trois sont en effet des produits groupés, mais d'autres produits groupés fonctionnent, comme celui-ci :
hidden link

Sur la version allemande par contre, ce même produit non plus ne fonctionne pas :
hidden link

Cordialement,

Benjamin

octobre 5, 2018 à 5:24 #2791429

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci Benjamin.

J'ai mis temporairement l'éditeur native de WooCommerce, et je vois qu'il existe plusieurs différences avec les ajustements entre le produits groupés problème et ses traductions. Par exemple, ils ne sont pas la valeur du "Wholesale Price for this product".

La solution plus directe et vérifier que les traductions de vos produits ont les mêmes ajustements que les originaux. Pour cela :
- Allez à WooCommerce > WooCommerce Multilingual > Paramètres
- Éditeur de traduction WPML
x Écran de traitement de produit WooCommerce natif
- Ouvrez la fiche d'édition de l'original.
- Dans une autre fenêtre ouvrez sa traduction et comparer.

Voyez-vous de différences ?

Documentation:
https://wpml.org/fr/documentation-6/projets-connexes/woocommerce-multilingual-operez-des-sites-de-commerce-electronique-en-plusieurs-langues/

octobre 5, 2018 à 5:48 #2791450

ludovicG-3

Merci pour ces précisions.

J'ai suivi vos instructions.

Je vois bien des différences et notamment le fait que sur les produits qui posent problème les "bundeled products" ne sont pas présents.
Je les ai ajoutés mais ils disparaissent après avoir sauvegardé la fiche produit.

octobre 6, 2018 à 8:32 #2792602

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Merci de partager vos résultats.

1. Est-ce que si vous créez et traduisez un nouveau produit groupé, tout fonctionne correctement ?

2. Si ce n'est pas le cas, il peut s'agir d'une bogue avec l'extension WooCommerce Product Bundles.

Pour cette raison je viens de créer une installation WordPress de test. Vous pouvez y accéder en cliquant le lien à continuation :
hidden link

Une fois vous êtes sur le Bureau du site, installez votre extension et essayez de reproduire cette situation. De cette manière, je peut transmettre ce site de test à notre Équipe de compatibilité.

Note: vous n'avez qu'installer le thème/extension nécessaire pour reproduire votre problématique. N'est pas nécessaire d'installer une copie exacte de votre site.

Cordialement

octobre 7, 2018 à 2:25 #2793888

ludovicG-3

Bonjour Andrés,

Je viens de tester en créant un nouveau produit groupé et lorsque je le traduis cela fonctionne.

La meilleure solution est-elle de recréer les produits qui posent problème et de les retraduire ?

Cordialement,

octobre 7, 2018 à 6:43 #2794135

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

D'après vos résultats, la bonne nouvelles est qu'il s'agit d'un problème lié à vos anciens produits groupés et pas un problème systématique de l'extension, très probablement une corruption des donnés de ces produits.

La solution plus simple, rapide et si vous ne rencontrez pas cette situation qu'avec 2-3 produits, il est effectivement de les recréer. Par contre, nous pouvons toujours continuer à investiguer si vous le souhaitez.

J'attends votre retour.

Cordialement,
Andrés

octobre 8, 2018 à 7:57 #2794998

ludovicG-3

Bonjour Andrés,

Je vais ressaisir les trois produits qui posent problème, c'est en effet la meilleure solution je pense.
En tout cas merci beaucoup pour votre aide !

Cordialement,

octobre 8, 2018 à 7:58 #2795000

ludovicG-3

My issue is resolved now. Thank you!

octobre 8, 2018 à 8:13 #2795077

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Parfait, Benjamin. Je suis ravi de savoir que vous pouvez continuer avec la traduction de votre site. 🙂
Je vous souhaite une belle journée.
Andrés

octobre 8, 2018 à 1:18 #2796105

ludovicG-3

Bonjour Andrés,

Comme convenu j'ai recréé un premier produit pour lequel tout a bien fonctionné : hidden link
Par contre pour le second produit, il y a toujours un souci : en anglais un seul des deux produits optionnels apparait et en allemand aucun n'apparait : hidden link

Je n'ai pas encore essayé de créer le troisième produit.

Merci par avance.

octobre 8, 2018 à 1:41 #2796172

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Pouvez-vous essayer le suivant :
- Effacez le produit en anglais.
- Videz aussi la Corbeille.
- Allez au produit original et dupliquez-le vers l'anglais.
- Traduisez-le.
Est-ce que cette fois il fonctionne ?

Dans le cas contraire, mettez temporairement l'éditeur de WooCommerce et vérifiez si la traduction en anglais du produit groupé a été créé correctement :
- WooCommerce > WooCommerce Multilingual > Paramètres
- Éditeur de traduction WPML
x Écran de traitement de produit WooCommerce natif

Cordialement

octobre 9, 2018 à 7:22 #2801758

ludovicG-3

Bonjour Andrés,

Je viens d'essayer ces manipulations mais ça ne fonctionne toujours pas : hidden link

Par ailleurs, j'ai vu qu'il y avait un bug d'affichage dans la traduction en anglais pour ce produit : hidden link. Le premier produit optionnel "Fork Bike Protect" n'est pas présenté comme le second "Stays protection". On peut le voir dans la pièce-jointe.

Merci par avance.

octobre 10, 2018 à 6:06 #2803041

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour,

Cela veut dire que pour tous les nouveaux produits groupés, la traduction pose de soucis ?

Si c'est le cas, j'ai besoin d'accéder à nouveau à votre site. Pouvez-vous réactiver vos identifiants car ils ne fonctionnent pas ?

Cordialement