Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

Our next available supporter will start replying to tickets in about 2.98 hours from now. Thank you for your understanding.

This topic contains 13 réponses, has 2 participants.

Last updated by Andrés il y a 1 an et 11 mois.

Assigned support staff: Andrés.

Auteur Messages
août 13, 2018 à 11:50 #2639657

boulouS

Je tente de : voir mes produits...

URL de (mon) site Internet où le problème apparaît : hidden link

Je m'attendais à voir : mes produits

À la place, j'ai obtenu : juste un produit par catégorie

août 13, 2018 à 12:30 #2639785

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bonjour Sandra,

Bienvenue à l'assistance technique de WPML.

Pour l'instant je n'ai pas de rapports similaires au votre :

1. Est-ce que si vous désactivez WPML la situation change ?

2. Pouvez-vous aller à vos Réglages > Permaliens et sauvegarder vos ajustements à nouveau ? Vous n'avez rien à modifier, simplement sauvegarder.

Cordialement,
Andrés

août 13, 2018 à 2:17 #2640146

boulouS

Bonjour Andrès, rien ne change quand je sauvegarde les permaliens et oui si je désactive WooCommerce multilingual je revois les produits ?? c'est bizarre je ne comprends pas :((

août 13, 2018 à 2:20 #2640171

boulouS

Je peux vous donner mes accès au site si vous voulez voir ? merci (le site est déjà dupliqué / sauvegardé mais pas par duplicator)

août 13, 2018 à 2:21 #2640175

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci, Sandra.

1. Si je comprends bien, cette situation est arrivé après la mise à jour de WooCommerce ?

2. Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress, pas l'information de débogage de WPML.

Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

août 13, 2018 à 2:32 #2640233

boulouS

ok je viens de faire le nécessaire

août 13, 2018 à 2:35 #2640248

boulouS

Debug :

[removed]

août 13, 2018 à 2:36 #2640251

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci mais cela n'est pas l'information demandé.

Est-ce que vous pouvez décrire d'une manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Si vous ne voyez pas le formulaire à continuation, ne publiez pas vos identifiants car cette information sera publique.
hidden link

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

août 13, 2018 à 4:23 #2640562

boulouS

J'ai juste fait les dernières mises à jour, une fois WooCommerce multilingual mis à jour je ne vois que un produit par catégorie, le 1er produit, très bizarre...

août 13, 2018 à 4:49 #2640640

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Merci de vos identifiants, Sandra. Néanmoins, je n'arrive pas à reproduire cette situation. J'ai activé notre WooCommerce Multilingual et les pages à continuation affichent leur produits sans soucis :
- hidden link
- hidden link
- hidden link

Est-ce que j'ai bien compris votre problème ? Dans le cas contraire, pouvez-vous me donner dés instructions détaillés pour le reproduire ?

Cordialement,
Andrés

août 13, 2018 à 5:00 #2640664

boulouS

Merci Andrès en fait j'ai désactivé un plugin :
WooCommerce Wishlist Plugin qui n'était pas à jour et il semble que le problème ne soit plus là... je fais re-tester demain si vous voulez bien. Je vous tiens au courant.
Très bonne soirée à vous,
Sandra

août 14, 2018 à 6:33 #2642347

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Bien trouvé, Sandra. J'attends votre retour.
Andrés

août 14, 2018 à 7:40 #2642534

boulouS

Bonjour Andrès, mon problème semble résolu, peut être le réglage des permaliens ? j'avais aussi désactivé le plugin de whislist...
Je vous remercie pour votre aide.
Bonne journée à vous.

août 14, 2018 à 8:29 #2642605

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+02:00)

Honnêtement, je ne peux pas vous dire mais je suis ravi de savoir que vous pouvez continuer avec la traduction de votre site. 🙂

Belle journée,
Andrés