Il s'agit du forum d'assistance technique de WPML, le plug-in multilingue pour WordPress.

Il est accessible à tous, toutefois seuls les clients de WPML peuvent y publier leurs messages. L'équipe de WPML répond aux messages du forum 6 jours sur 7, 22 heures sur 24.

This topic contains 14 réponses, has 2 participants.

Last updated by Andrés il y a 3 ans et 8 mois.

Assigned support staff: Andrés.

Auteur Messages
janvier 8, 2016 à 4:56 #783845

smartwebasia

Bonjour,

Les attributs ne se traduisent plus sur les pages produits depuis un certain moment.
C'est lié à un plugin (Visual attributes) qui est installé sur mon site et qui bug avec WPML.

J'ai fait un demande de support (aux dev concernés) à ce sujet mais j'en profite pour vous demander votre avis et votre expertise au cas où vous auriez une idée de l'origine de l'erreur.

Visual attributes - (hidden link)

Merci,

Mike

janvier 8, 2016 à 8:52 #784036

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Mike,

Bienvenue à l'assistance technique de WPML.

1. C'est super que vous avez déjà identifié l'origine de la incompatibilité. Effectivement, l'extension 'Visual attributes' n'apparait sur notre liste de compatibilité :
https://wpml.org/documentation/plugins-compatibility/

Vous pouvez proposer à l'auteur de ce plugin de s'inscrire au programme Go-Global, ou notre equipe de compatibilité pourrait aider à l'auteur à faire son extension prête à être compatible et d'accélérer cette procedure :
https://wpml.org/documentation/theme-compatibility/go-global-program/

2. D'un autre coté, je comprend le mal fonctionnement de la traduction des attributes, mais est-ce que cela genere une information d'erreur ?

Cela serait très utile si vous pouviez me fournir l'information du debug.log de WordPress. S'il vous plaît, lisez ces instructions:
https://wpml.org/documentation/support/debugging-wpml/
Est-ce que vous pouvez ouvrir le fichier wp-config.php et chercher la ligne: define(‘WP_DEBUG’, false); et la remplacer par:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );

Après, est-ce que vous pouvez chercher dans le dossier /wp-content/ s'il existe un fichier debug.log.
Pourriez-vous copier et coller le contenu du fichier debug.log dans pastebin.com et me fournir le lien, cela serait très utile (C'est la manière plus simple car parfois les logs sont volumineux et polluer notre conversation sur ce forum).

J'attend votre retour.

Cordialement,
Andrés

janvier 10, 2016 à 11:53 #784449

smartwebasia

Bonjour,

Merci pour vos réponses,

1) OK je viens de faire suivre l'information et le lien aux dev.

2) OUi c'est activé, je peux vous envoyer le debug...je préfère vous envoyer le fichier svp mais comment ?

Merci encore,

Mike

janvier 11, 2016 à 7:40 #785309

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Est-ce que vous pouvez décrire de manière détaillée comment répliquer ce comportement ?

Afin de mieux cerner le problème, je vais avoir besoin d’un accès temporaire à votre site (wp-admin et FTP). Idéalement sur un site de test où le problème a été si possible répliqué.
Vous trouverez sous la zone de commentaires, les champs nécessaires (quand vous êtes connecté) à remplir dans votre prochaine réponse. Les informations que vous allez saisir sont privées, ce qui signifie que seul vous et moi y auront accès.

*Important: Assurez-vous de créer une sauvegarde de la base de données ainsi comme de votre site avant de proceder ! Vous pouvez utiliser une extension comme le plugin Duplicator.
Consultez: http://wordpress.org/plugins/duplicator/

Sécurité au moment de fournir l’information de debug à l’assistance technique:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/"

janvier 18, 2016 à 12:44 #790118

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Mike,

Je suis ravi de savoir que presque tous vos petits inconvénients ont été résolu. Néanmoins, je viens d'accéder à votre site et je n'ai pas pu répliquer ce comportement. J'ai visité des produits en anglais et en français comme :
- hidden link
- hidden link

Est-ce que vous pouvez me dire si vous avez trouvé une solution ou des autres produits dont je peux inspecter ?

Cordialement,
Andrés

janvier 18, 2016 à 10:46 #790623

smartwebasia

Bonjour Andrés,

Désolé, j'avais tout simplement désactivé le plugin pour faire d'autres test.
J'ai réactivé le plugin qui semble posé problème avec WPML.

Vous pouvez vérifier maintenant,

Merci encore,

Mike

janvier 19, 2016 à 1:39 #791247

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Mike,

Je suis désolé de ne pas l'avoir remarqué.

Finalement, j'ai créé une copie avec Duplicator plugin, puis je j'ai l'installé en local. J'ai tout désactivé sauf 'QueryLoop Visual Attributes', WPML et WooCommerce et le problème était toujours présent. Après j'ai mis à jour l'extension WooCommerce et WordPress 4.41, toujours la même situation.

Dans ce perspective, pour assurer que ce plugin est compatible avec WPML, nous avons besoin de contacter l'auteur du plugin et travailler avec lui pour résoudre ce problème.
Est-ce que vous pouvez nous donner le lien de la page du plugin, ainsi comme son information de contact (email) pour lui contacter ?

Cordialement,
Andrés

janvier 19, 2016 à 3:16 #791384

smartwebasia

Bonjour,

Génial...vous avez même jusqu'à recréer une copie en local. Merci beaucoup !

..........Est-ce que vous pouvez nous donner le lien de la page du plugin, ainsi comme son information de contact (email) pour lui contacter ?..........

Voici les différents liens pour contacter l'auteur du plugin :

Page auteur sur themeforest : hidden link

Page du plugin sur themeforest : hidden link

Site internet du plugin : hidden link

Dites moi si je peux faire quoi que ce soit de plus pour faire avancer ce problème.

Merci encore,

Mike

janvier 19, 2016 à 3:49 #791415

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Merci pour les informations, Mike.

Nous allons contacter l'auteur et lui proposer de rendre son extension compatible avec WPML. Néanmoins, je ne peux pas vous donner de délai pour ce processus car cela dépend en grande partie de l'auteur. Je vous invite d'ailleurs à le contacter directement afin d'appuyer notre contact.

Nous vous tiendrons informés dès que nous avons reçu une réponse de l'auteur.

Cordialement,
Andrés

janvier 19, 2016 à 4:06 #791430

smartwebasia

Bonjour,

Merci beaucoup pour votre efficacité.
Je vais immédiatement contacter l'auteur pour appuyer la demande.

Je vous remercie encore de votre aide et je vous tiens au courant à la moindre évolution.

Cordialement,

Mike

janvier 19, 2016 à 4:33 #791453

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

J'espere que nous pouvons trouver une solution ensemble rapidement, Mike et je vous remercie aussi pour votre disposition. Je vous tiens au courant des advances.

Cordialement,
Andrés

février 3, 2016 à 11:13 #804312

smartwebasia

Bonjour Andrés,

j'espère que vous allez bien.
J'ai reçu un première réponse du DEV après des semaines de silence.

.................

Hi Mike,

We where able to replicate this same issue, regarding WPML. The name of the attribute doesn’t translate and, also, the attributes don’t show up.

We are investigating it, and will let you know in the coming days. Unfortunately, and as you may already know, this can take more time.

Also, I wanted to thank you for the WPML Go-Global Program link. Will see if that helps us speed things up.

.................

Avez-vous des nouvelles de votre coté ?

Cordialement,

Mike

février 4, 2016 à 7:43 #804454

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Mike,

Je suis ravi de savoir que votre auteur vous a répondu. Certainement, cela va nous aider à trouver une solution plus rapidement. De notre coté, je n'ai rien de concret pour l'instant.

Je vous tiens au courant des avances.

Cordialement,
Andrés

mars 7, 2016 à 8:27 #831297

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Mike,

Je viens d'avoir un feedback de notre Équipe de Compatibilité, est-ce que vous pouvez nous fournir un e-mail de l'auteur ?

Merci de votre aide.

Cordialement,
Andrés

avril 1, 2016 à 10:22 #851044

Andrés
Supporter

Languages: Anglais (English ) Espagnol (Español ) Français (Français )

Timezone: Europe/Paris (GMT+01:00)

Bonjour Mike,

Est-ce que vous avez eu des nouvelles?

Cordialement,
Andrés

Le sujet ‘[Fermé] Attributs qui ne se traduisent pas sur page produit’ est fermé à de nouvelles réponses.